Introduction

InfraRecorder
Introduction

Bienvenue

Merci d'avoir installé InfraRecorder! InfraRecorder est une solution de gravure CD/DVD gratuite pour Windows.

Navigation rapide

Aperçu des fonctionnalités
Accord de licence en Français
Accord de licence en Anglais (officielle)
Configuration requise
Démarrage rapide
Copyright
Accords
Quoi de neuf
Installation

Fichier d'aide InfraRecorder Version 0.50.0.0 - traduction: Olivier HIGELIN


Aperçu des fonctionnalités

InfraRecorder
Aperçu des fonctionnalités

Cette page liste les fonctions essentielles de InfraRecorder.

Fonctions principales

  • Crée des projets de données personnelles, musique, et mixte puis les stocker sur un média physique ou dans un fichier image.
  • Crée et enregistrer des images de disques.
  • Crée des copies directes de disques, à la volée, ou en utilisant une image disque temporaire.
  • Efface des disques ré-inscriptibles par le biais de quatre différentes méthodes.
  • Importe des données de sessions issues d'un disque multi-session et lui rajouter d'autre sessions.
  • Clôture les disques (écriture d'information en épilogue pour empêcher toute rajout de données au disque).
  • Recherche des périphériques sur bus SCSI/IDE et collecte des informations détaillées sur leur capacités.
  • Affiche des informations disque détaillées.
  • Lit et sauvegarde des données et pistes audios dans des fichiers (wav. et .iso)
  • Balaye les pistes sélectionnées à la recherche d'erreur.

Environment

  • Interface moderne et paramétrable du type "explorateur Windows".
  • Glisser/déposer de fichiers d'une vue de l'explorateur Windows vers une vue projet.
  • Vues de projets différentes suivant le type de projet pour permettre à l'utilisateur de travailler plus facilement.
  • ??? Features a separate express application designed to guide the user to the most essential tools as quick and easy as possible.
  • Une interface multilingue pour l'application principale, et l'extension du shell.

Integration dans l'explorateur

S'intègre à l'explorateur et ajoute de nouvelles options au menu contextuel.

  • Grave les projets et images disque enregistrés.
  • Ouvre et édite un projet enregistré.
  • Pleinement paramétrable, les commandes peuvent s'afficher dans un sous-menu avec ou sans icônes.
  • L'extension shell peut être associées avec n'importe quelle type d'extension définie par l'utilisateur.


Accord de licence

InfraRecorder
Accord de licence

LICENCE PUBLIQUE GÉNÉRALE GNU

Version 3, du 29 juin 2007

Copyright © 2007 Free Software Foundation, Inc. <http://fsf.org/>

Chacun est autorisé à copier et distribuer des copies conformes de ce document de licence, mais toute modification en est proscrite.

Traduction française par Philippe Verdy, le 30 juin 2007.

Avertissement important au sujet de cette traduction française.

Ceci est une traduction en français de la licence “GNU General Public License” (GPL). Cette traduction est fournie ici dans l’espoir qu’elle facilitera sa compréhension, mais elle ne constitue pas une traduction officielle ou approuvée d’un point de vue juridique.

La Free Software Foundation (FSF) ne publie pas cette traduction et ne l’a pas approuvée en tant que substitut valide au plan légal pour la licence authentique “GNU General Public Licence”. Cette traduction n’a pas encore été passée en revue attentivement par un juriste et donc le traducteur ne peut garantir avec certitude qu’elle représente avec exactitude la signification légale des termes de la licence authentique “GNU General Public License” publiée en anglais. Cette traduction n’établit donc légalement aucun des termes et conditions d’utilisation d’un logiciel sous licence GNU GPL — seul le texte original en anglais le fait. Si vous souhaitez être sûr que les activités que vous projetez seront autorisées par la GNU General Public License, veuillez vous référer à sa seule version anglaise authentique.

La FSF vous recommande fermement de ne pas utiliser cette traduction en tant que termes officiels pour vos propres programmes ; veuillez plutôt utiliser la version anglaise authentique telle que publiée par la FSF. Si vous choisissez d’acheminer cette traduction en même temps qu’un Programme sous licence GNU GPL, cela ne vous dispense pas de l’obligation d’acheminer en même temps une copie de la licence authentique en anglais, et de conserver dans la traduction cet avertissement important en français et son équivalent en anglais ci-dessous.

Important Warning About This French Translation.
This is a translation of the GNU General Public License (GPL) into French. This translation is distributed in the hope that it will facilitate understanding, but it is not an official or legally approved translation.

The Free Software Foundation (FSF) is not the publisher of this translation and has not approved it as a legal substitute for the authentic GNU General Public License. The translation has not been reviewed carefully by lawyers, and therefore the translator cannot be sure that it exactly represents the legal meaning of the authentic GNU General Public License published in English. This translation does not legally state the terms and conditions of use of any Program licenced under GNU GPL — only the original English text of the GNU LGPL does that. If you wish to be sure whether your planned activities are permitted by the GNU General Public License, please refer to its sole authentic English version.

The FSF strongly urges you not to use this translation as the official distribution terms for your programs; instead, please use the authentic English version published by the FSF. If you choose to convey this translation along with a Program covered by the GPL Licence, this does not remove your obligation to convey at the same time a copy of the authentic GNU GPL License in English, and you must keep in this translation this important warning in English and its equivalent in French above.

Préambule

La Licence Publique Générale GNU (“GNU General Public License”) est une licence libre, en “copyleft”, destinée aux œuvres logicielles et d’autres types de travaux.

Les licences de la plupart des œuvres logicielles et autres travaux de pratique sont conçues pour ôter votre liberté de partager et modifier ces travaux. En contraste, la Licence Publique Générale GNU a pour but de garantir votre liberté de partager et changer toutes les versions d’un programme — afin d’assurer qu’il restera libre pour tous les utilisateurs. Nous, la Free Software Foundation, utilisons la Licence Publique Générale GNU pour la plupart de nos logiciels ; cela s’applique aussi à tout autre travail édité de cette façon par ses
auteurs. Vous pouvez, vous aussi, l’appliquer à vos propres programmes.

Quand nous parlons de logiciel libre (“free”), nous nous référons à la liberté (“freedom”), pas au prix. Nos Licences Publiques Générales sont conçues pour assurer que vous ayez la liberté de distribuer des copies de logiciel libre (et le facturer si vous le souhaitez), que vous receviez le code source ou pouviez l’obtenir si vous le voulez, que vous pouviez modifier le logiciel ou en utiliser toute partie dans de nouveaux logiciels libres, et que vous sachiez que vous avez le droit de faire tout ceci.

Pour protéger vos droits, nous avons besoin d’empêcher que d’autres vous restreignent ces droits ou vous demande de leur abandonner ces droits. En conséquence, vous avez certaines responsabilités si vous distribuez des copies d’un tel programme ou si vous le modifiez : les responsabilités de respecter la liberté des autres.

Par exemple, si vous distribuez des copies d’un tel programme, que ce soit gratuit ou contre un paiement, vous devez accorder aux Destinataires les mêmes libertés que vous avez reçues. Vous devez aussi vous assurer qu’eux aussi reçoivent ou peuvent recevoir son code source. Et vous devez leur montrer les termes de cette licence afin qu’ils connaissent leurs droits.

Les développeurs qui utilisent la GPL GNU protègent vos droits en deux étapes : (1) ils affirment leur droits d’auteur (“copyright”) sur le logiciel, et (2) vous accordent cette Licence qui vous donne la permission légale de le copier, le distribuer et/ou le modifier.

Pour la protection des développeurs et auteurs, la GPL stipule clairement qu’il n’y a pas de garantie pour ce logiciel libre. Aux fins à la fois des utilisateurs et auteurs, la GPL requière que les versions modifiées soient marquées comme changées, afin que leurs problèmes ne soient pas attribués de façon erronée aux auteurs des versions précédentes.

Certains dispositifs sont conçus pour empêcher l’accès des utilisateurs à l’installation ou l’exécution de versions modifiées du logiciel à l’intérieur de ces dispositifs, alors que les fabricants le peuvent. Ceci est fondamentalement incompatible avec le but de protéger la liberté des utilisateurs de modifier le logiciel. L’aspect systématique de tels abus se produit dans le secteur des produits destinés aux utilisateurs individuels, ce qui est précidément ce qui est le plus inacceptable. Aussi, nous avons conçu cette version de la GPL pour prohiber cette pratique pour ces produits. Si de tels problèmes surviennent dans d’autres domaines, nous nous tenons prêt à étendre cette restriction à ces domaines dans de futures versions de la GPL, autant qu’il sera nécessaire pour protéger la liberté des utilisateurs.

Finalement, chaque programme est constamment menacé par les brevets logiciels. Les États ne devraient pas autoriser de tels brevets à restreindre le développement et l’utilisation de logiciels libres sur des ordinateurs d’usage général ; mais dans ceux qui le font, nous voulons spécialement éviter le danger que les brevets appliqués à un programme libre puisse le rendre effectivement propriétaire. Pour empêcher ceci, la GPL assure que les brevets ne peuvent être utilisés pour rendre le programme non-libre.

Les termes précis et conditions concernant la copie, la distribution et la modification suivent.

TERMES ET CONDITIONS

0. Definitions.

« Cette Licence » se réfère à la version 3 de la “GNU General Public License” (le texte original en anglais).

« Droit d’Auteur » signifie aussi les droits du “copyright” ou voisins qui s’appliquent à d’autres types de travaux, tels que ceux sur les masques de semi-conducteurs.

« Le Programme » se réfère à tout travail qui peut être sujet au Droit d’Auteur (“copyright”) et dont les droits d’utilisation sont concédés en vertu de cette Licence. Chacun des Licenciés, à qui cette Licence est concédée, est désigné par « vous. » Les « Licenciés » et les « Destinataires » peuvent être des personnes physiques ou morales (individus ou organisations).

« Modifier » un travail signifie en obtenir une copie et adapter tout ou partie du travail d’une façon nécessitant une autorisation d’un titulaire de Droit d’Auteur, autre que celle permettant d’en produire une copie conforme. Le travail résultant est appelé une « version modifiée » du précédent travail, ou un travail « basé sur » le précédent travail.

Un « Travail Couvert » signifie soit le Programme non modifié soit un travail basé sur le Programme.

« Propager » un travail signifie faire quoi que ce soit avec lui qui, sans permission, vous rendrait directement ou indirectement responsable d’un délit de contrefaçon suivant les lois relatives au Droit d’Auteur, à l’exception de son exécution sur un ordinateur ou de la modification d’une copie privée. La propagation inclue la copie, la distribution (avec ou sans modification), la mise à disposition envers le public, et aussi d'autres activités dans certains pays.

« Acheminer » un travail signifie tout moyen de propagation de celui-ci qui permet à d’autres parties de réaliser ou recevoir des copies. La simple interaction d’un utilisateur à travers un réseau informatique, sans transfert effectif d’une copie, ne constitue pas un acheminement.

Une interface utilisateur interactive affiche des « Notices Légales Appropriées » quand elle comprend un dispositif convenable, bien visible et évident qui (1) affiche une notice appropriée sur les droits d’auteur et (2) informe l’utilisateur qu’il n’y a pas de garantie pour le travail (sauf si des garanties ont été fournies hors du cadre de cette Licence), que les licenciés peuvent acheminer le travail sous cette Licence, et comment voir une copie de cette Licence. Si l’interface présente une liste de commandes utilisateur ou d’options, tel qu’un menu, un élément évident dans la liste présentée remplit ce critère.

1. Code source.

Le « code source » d’un travail signifie la forme préférée du travail permettant ou facilitant les modifications de celui-ci. Le « code objet » d’un travail signifie toute forme du travail qui n’en est pas le code source.

Une « Interface Standard » signifie une interface qui est soit celle d’une norme officielle définie par un organisme de normalisation reconnu ou, dans le cas des interfaces spécifiées pour un langage de programmation particulier, une interface largement utilisée parmi les développeurs travaillant dans ce langage.

Les « Bibliothèques Système » d’un travail exécutable incluent tout ce qui, en dehors du travail dans son ensemble, (a) est inclus dans la forme usuelle de paquetage d’un Composant Majeur mais ne fait pas partie de ce Composant Majeur et (b) sert seulement à permettre l’utilisation du travail avec ce Composant Majeur ou à implémenter une Interface Standard pour laquelle une implémentation est disponible au public sous forme de code source ; un « Composant Majeur » signifie, dans ce contexte, un composant majeur essentiel (noyau, système de fenêtrage, etc.) du système d’exploitation (le cas échéant) d’un système sur lequel le travail exécutable fonctionne, ou bien un compilateur utilisé pour produire le code objet du travail, ou un interprète de code objet utilisé pour exécuter celui-ci.

Le « Source Correspondant » d’un travail sous forme de code objet signifie l’ensemble des codes sources nécessaires pour générer, installer et (dans le cas d’un travail exécutable) exécuter le code objet et modifier le travail, y compris les scripts pour contrôler ces activités. Cependant, cela n’inclue pas les Bibliothèques Système du travail, ni les outils d’usage général ou les programmes libres généralement disponibles qui peuvent être utilisés sans modification pour achever ces activités mais ne sont pas partie de ce travail. Par exemple le Source Correspondant inclut les fichiers de définition d’interfaces associés aux fichiers sources du travail, et le code source des bibliothèques partagées et des sous-routines liées
dynamiquement, pour lesquelles le travail est spécifiquement conçu pour les requérir via, par exemple, des communications de données ou contrôles de flux internes entre ces sous-programmes et d’autres parties du travail.

Le Source Correspondant n’a pas besoin d’inclure tout ce que les utilisateurs peuvent regénérer automatiquement à partir d’autres parties du Source Correspondant.
Le Source Correspondant pour un travail sous forme de code source est ce même travail.

2. Permissions de base.

Tous les droits accordés suivant cette Licence le sont jusqu’au terme des Droits d’Auteur (“copyright”) sur le Programme, et sont irrévocables pourvu que les conditions établies soient remplies. Cette Licence affirme explicitement votre permission illimitée d’exécuter le Programme non modifié. La sortie produite par l’exécution d’un Travail Couvert n’est couverte par cette Licence que si cette sortie, étant donné leur contenu, constitue un Travail Couvert. Cette Licence reconnait vos propres droits d’usage raisonnable (“fair use” en
législation des États-Unis d’Amérique) ou autres équivalents, tels qu’ils sont pourvus par la loi applicable sur le Droit d’Auteur (“copyright”).

Vous pouvez créer, exécuter et propager sans condition des Travaux Couverts que vous n’acheminez pas, aussi longtemps que votre licence demeure en vigueur. Vous pouvez acheminer des Travaux Couverts à d’autres personnes dans le seul but de leur faire réaliser des modifications à votre usage exclusif, ou pour qu’ils vous fournissent des facilités vous permettant d’exécuter ces travaux, pourvu que vous vous conformiez aux termes de cette Licence lors de l’acheminement de tout matériel dont vous ne contrôlez pas le Droit d’Auteur (“copyright”). Ceux qui, dès lors, réalisent ou exécutent pour vous les Travaux Couverts ne doivent alors le faire qu’exclusivement pour votre propre compte, sous votre direction et votre contrôle, suivant des termes qui leur interdisent de réaliser, en dehors de leurs relations avec vous, toute copie de votre matériel soumis au Droit d’Auteur.

L’acheminement dans toutes les autres circonstances n’est permis que selon les conditions établies ci-dessous. La concession de sous-licences n’est pas autorisé ; l’article 10 rend cet usage non nécessaire.

3. Protection des droits légaux des utilisateurs envers les lois anti-contournement.

Aucun Travail Couvert ne doit être vu comme faisant partie d’une mesure technologique effective selon toute loi applicable remplissant les obligations prévues à l’article 11 du traité international sur le droit d’auteur adopté à l’OMPI le 20 décembre 1996, ou toutes lois similaires qui prohibent ou restreignent le contournement de telles mesures.

Si vous acheminez un Travail Couvert, vous renoncez à tout pouvoir légal d’interdire le contournement des mesures technologiques dans tous les cas où un tel contournement serait effectué en exerçant les droits prévus dans cette Licence pour ce Travail Couvert, et vous déclarez rejeter toute intention de limiter l’opération ou la modification du Travail, en tant que moyens de renforcer, à l’encontre des utilisateurs de ce Travail, vos droits légaux ou ceux de tierces parties d’interdire le contournement des mesures technologiques.

4. Acheminement des copies conformes.

Vous pouvez acheminer des copies conformes du code source du Programme tel que vous l’avez reçu, sur n’importe quel support, pourvu que vous publiiez scrupuleusement et de façon appropriée sur chaque copie une notice de Droit d’Auteur appropriée ; gardez intactes toutes les notices établissant que cette Licence et tous les termes additionnels non permissifs ajoutés en accord avec l’article 7 s’appliquent à ce code ; et donnez à chacun des Destinataires une copie de cette Licence en même temps que le Programme.

Vous pouvez facturer à un prix quelconque, y compris gratuit, chacune des copies que vous acheminez, et vous pouvez offrir une protection additionnelle de support ou de garantie en échange d’un paiement.

5. Acheminement des versions sources modifiées.

Vous pouvez acheminer un travail basé sur le Programme, ou bien les modifications pour le produire à partir du Programme, sous la forme de code source suivant les termes de l’article 4, pourvu que voussatisfassiez aussi à chacune des conditions requises suivantes :

  • a) Le travail doit comporter des notices évidentes établissant que vous l’avez modifié et donnant la date correspondante.
  • b) Le travail doit comporter des notices évidentes établissant qu’il est édité selon cette Licence et les conditions ajoutées d’après l’article 7. Cette obligation vient modifier l’obligation de l’article 4 de « garder intactes toutes les notices. ».
  • c) Vous devez licencier le travail entier, comme un tout, suivant cette Licence à quiconque entre en possession d’une copie. Cette Licence s’appliquera en conséquence, avec les termes additionnels applicables prévus par l’article 7, à la totalité du travail et chacune de ses parties, indépendamment de la façon dont ils sont empaquetés. Cette licence ne donne aucune permission de licencier le travail d’une autre façon, mais elle n’invalide pas une telle permission si vous l’avez reçue séparément.
  • d) Si le travail a des interfaces utilisateurs interactives, chacune doit afficher les Notices Légales Appropriées ; cependant si le Programme a des interfaces qui n’affichent pas les Notices Légales Appropriées, votre travail n’a pas à les modifier pour qu’elles les affichent.

Une compilation d’un Travail Couvert avec d’autres travaux séparés et indépendants, qui ne sont pas par leur nature des extensions du Travail Couvert, et qui ne sont pas combinés avec lui de façon à former un programme plus large, dans ou sur un volume de stockage ou un support de distribution, est appelé un « aggrégat » si la compilation et son Droit d’Auteur résultant ne sont pas utilisés pour limiter l’accès ou les droits légaux des utilisateurs de la compilation en deça de ce que permettent les travaux individuels. L’inclusion d’un Travail Couvert dans un aggrégat ne cause pas l’application de cette Licence aux autres parties de l’aggrégat.

6. Acheminement des formes non sources.

Vous pouvez acheminer sous forme de code objet un Travail Couvert suivant les termes des articles 4 et 5, pourvu que vous acheminiez également suivant les termes de cette Licence le Source Correspondantlisible par une machine, d’une des façons suivantes :

  • a) Acheminer le code objet sur, ou inclus dans, un produit physique (y compris un support de distribution physique), accompagné par le Source Correspondant fixé sur un support physique durable habituellement utilisé pour les échanges de logiciels.
  • b) Acheminer le code objet sur, ou inclus dans, un produit physique (y compris un support de distribution physique), accompagné d’une offre écrite, valide pour au moins trois années et valide pour aussi longtemps que vous fournissez des pièces de rechange ou un support client pour ce modèle de produit, afin de donner à quiconque possède le code objet soit (1) une copie du Source Correspondant à tout logiciel dans ce produit qui est couvert par cette Licence, sur un support physique durable habituellement utilisé pour les échanges de logiciels, pour un prix non supérieur au coût raisonnable de la réalisation physique de l’acheminement de la source, ou soit (2) un accès permettant de copier le Source Correspondant depuis un serveur réseau sans frais.
  • c) Acheminer des copies individuelles du code objet avec une copie de l’offre écrite de fournir le Source Correspondant. Cette alternative est permise seulement occasionellement et non commercialement, et seulement si vous avez reçu le code objet avec une telle offre, en accord avec l’article 6 alinéa b.
  • d) Acheminer le code objet en offrant un accès depuis un emplacement désigné (gratuit ou contre facturation) et offrir un accès équivalent au Source Correspondant de la même façon via le même emplacement et sans facturation supplémentaire. Vous n’avez pas besoin d’obliger les Destinataires à copier le Source Correspondant en même temps que le code objet. Si l’emplacement pour copier le code objet est un serveur réseau, le Source Correspondant peut être sur un serveur différent (opéré par vous ou par un tiers) qui supporte des facilités équivalentes de copie, pourvu que vous mainteniez des directions claires à proximité du code objet indiquant où trouver le Source Correspondant. Indépendamment de quel serveur héberge le Source Correspondant, vous restez obligé de vous assurer qu’il reste disponible aussi longtemps que nécessaire pour satisfaire à ces obligations.
  • e) Acheminer le code objet en utilisant une transmission d’égal-à-égal, pourvu que vous informiez les autres participants sur où le code objet et le Source Correspondant du travail sont offerts sans frais au public général suivant l’article 6 alinéa d. Une portion séparable du code objet, dont le code source est exclu du Source Correspondant en tant que Bibliothèque Système, n’a pas besoin d’être inclu dans l’acheminement du travail sous forme de code objet.

A separable portion of the object code, whose source code is excluded from the Corresponding Source as a System Library, need not be included in conveying the object code work.

Un « Produit Utilisateur » est soit (1) un « Produit de Consommation, » ce qui signifie toute propriété personnelle tangible normalement utilisée à des fins personnelles, familiales ou relatives au foyer, soit (2) toute chose conçue ou vendue pour l’incorporation dans un lieu d’habitation. Pour déterminer si un produit constitue un Produit de Consommation, les cas ambigus sont résolus en fonction de la couverture. Pour un produit particulier reçu par un utilisateur particulier, l’expression « normalement utilisée » ci-avant se réfère à une utilisation typique ou l’usage commun de produits de même catégorie, indépendamment du statut de cet utilisateur particulier ou de la façon spécifique dont cet utilisateur particulier utilise effectivement ou s’attend lui-même ou est attendu à utiliser ce produit. Un produit est un Produit de Consommation indépendamment du fait que ce produit a ou n’a pas d’utilisations substantielles commerciales, industrielles ou hors Consommation, à moins que de telles utilisations représentent le seul mode significatif d’utilisation duproduit.

Les « Informations d’Installation » d’un Produit Utilisateur signifient toutes les méthodes, procédures, clés d’autorisation ou autres informations requises pour installer et exécuter des versions modifiées d’un Travail Couvert dans ce Produit Utilisateur à partir d’une version modifiée de son Source Correspondant. Les informations qui suffisent à assurer la continuité de fonctionnement du code objet modifié ne doivent en aucun cas être empêchées ou interférées du seul fait qu’unemodification a été effectuée.

Si vous acheminez le code objet d’un Travail Couvert dans, ou avec, ou spécifiquement pour l’utilisation dans, un Produit Utilisateur et l’acheminement se produit en tant qu’élément d’une transaction dans laquelle le droit de possession et d’utilisation du Produit Utilisateur est transféré au Destinataire définitivement ou pour un terme fixé (indépendamment de la façon dont la transaction est caractérisée), le Source Correspondant acheminé selon cet article-ci doit être accompagné des Informations d’Installation. Mais cette obligation ne s’applique pas si ni vous ni aucune tierce partie ne détient la possibilité d’intaller un code objet modifié sur le ProduitUtilisateur (par exemple, le travail a été installé en mémoire morte).

L’obligation de fournir les Informations d’Installation n’inclue pas celle de continuer à fournir un service de support, une garantie ou des mises à jour pour un travail qui a été modifié ou installé par le Destinataire, ou pour le Produit Utilisateur dans lequel il a été modifié ou installé. L’accès à un réseau peut être rejeté quand la modification elle-même affecte matériellement et défavorablement les opérations du réseau ou viole les règles et protocoles de communication au travers du réseau.

Le Source Correspondant acheminé et les Informations d’Installation fournies, en accord avec cet article, doivent être dans un format publiquement documenté (et dont une implémentation est disponible auprès du public sous forme de code source) et ne doit nécessiter aucune clé ou mot de passe spécial pour le dépaquetage, la lecture oula copie.

7. Termes additionnels.

Les « permissions additionelles » désignent les termes qui supplémentent ceux de cette Licence en émettant des exceptions à l’une ou plusieurs de ses conditions. Les permissions additionnelles qui sont applicables au Programme entier doivent être traitées comme si elles étaient incluent dans cette Licence, dans les limites de leur validité suivant la loi applicable. Si des permissions additionnelles s’appliquent seulement à une partie du Programme, cette partie peut être utilisée séparément suivant ces permissions, mais le Programme tout entier reste gouverné par cette Licence sans regard auxpermissions additionelles.

Quand vous acheminez une copie d’un Travail Couvert, vous pouvez à votre convenance ôter toute permission additionelle de cette copie, ou de n’importe quelle partie de celui-ci. (Des permissions additionnelles peuvent être rédigées de façon à requérir leur propre suppression dans certains cas où vous modifiez le travail.) Vous pouvez placer les permissions additionnelles sur le matériel acheminé, ajoutées par vous à un Travail Couvert pour lequel vous avez ou pouvezdonner les permissions de Droit d’Auteur (“copyright”) appropriées.

Nonobstant toute autre clause de cette Licence, pour tout constituant que vous ajoutez à un Travail Couvert, vous pouvez (si autorisé par les titulaires de Droit d’Auteur pour ce constituant) supplémenter lestermes de cette Licence avec des termes :

  • a) qui rejettent la garantie ou limitent la responsabilité de façon différente des termes des articles 15 et 16 de cette Licence ; ou
  • b) qui requièrent la préservation de notices légales raisonnables spécifiées ou les attributions d’auteur dans ce constituant ou dans les Notices Légales Appropriées affichées par les travaux qui le contiennent ; ou
  • c) qui prohibent la représentation incorrecte de l’origine de ce constituant, ou qui requièrent que les versions modifiées d’un tel constituant soit marquées par des moyens raisonnables comme différentes de la version originale ; ou
  • d) qui limitent l’usage à but publicitaire des noms des concédants de licence et des auteurs du constituant ; ou
  • e) qui refusent à accorder des droits selon la législation relative aux marques commerciales, pour l’utilisation dans des noms commerciaux, marques commerciales ou arques de services ; ou
  • f) qui requièrent l’indemnisation des concédants de licences et auteurs du constituant par quiconque achemine ce constituant (ou des versions modifiées de celui-ci) en assumant contractuellement la responsabilité envers le Destinataire, pour toute responsabilité que ces engagements contractuels imposent directement à ces octroyants de licences et auteurs.

Tous les autres termes additionnels non permissifs sont considérés comme des « restrictions avancées » dans le sens de l’article 10. Si le Programme tel que vous l’avez reçu, ou toute partie de celui-ci, contient une notice établissant qu’il est gouverné par cette Licence en même temps qu’un terme qui est une restriction avancée, vous pouvez ôter ce terme. Si un document de licence contient une restriction avancée mais permet la reconcession de licence ou l’acheminement suivant cette Licence, vous pouvez ajouter un Travail Couvert constituant gouverné par les termes de ce document de licence, pourvu que la restriction avancée ne survit pas à un telle cession de licenceou acheminement.

Si vous ajoutez des termes à un Travail Couvert en accord avec cet article, vous devez placer, dans les fichiers sources appropriés, une déclaration des termes additionnels qui s’appliquent à ces fichiers, ou une notice indiquant où trouver les termes applicables.

Les termes additionnels, qu’ils soient permissifs ou non permissifs, peuvent être établis sous la forme d’une licence écrite séparément, ou établis comme des exceptions ; les obligations ci-dessus s’appliquentdans chacun de ces cas.

8. Terminaison.

Vous ne pouvez ni propager ni modifier un Travail Couvert autrement que suivant les termes de cette Licence. Toute autre tentative de le propager ou le modifier est nulle et terminera automatiquement vos droits selon cette Licence (y compris toute licence de brevet accordée selon le troisième paragraphe de l’article 11).

Cependant, si vous cessez toute violation de cette Licence, alors votre licence depuis un titulaire de Droit d’Auteur (“copyright”) est réinstaurée (a) à titre provisoire à moins que et jusqu’à ce que le titulaire de Droit d’Auteur termine finalement et explicitement votre licence, et (b) de façon permanente si le titulaire de Droit d’Auteur ne parvient pas à vous notifier de la violation par quelque moyenraisonnable dans les soixante (60) jours après la cessation.

De plus, votre licence depuis un titulaire particulier de Droit d’Auteur est réinstaurée de façon permanente si ce titulaire vous notifie de la violation par quelque moyen raisonnable, c’est la première fois que vous avez reçu une notification deviolation de cette Licence (pour un travail quelconque) depuis ce titulaire de Droit d’Auteur, et vous résolvez la violation dans les trente (30) jours quisuivent votre réception de la notification.

La terminaison de vos droits suivant cette section ne terminera pas les licences des parties qui ont reçu des copies ou droits de votre part suivant cette Licence. Si vos droits ont été terminés et non réinstaurés de façon permanente, vous n’êtes plus qualifié à recevoirde nouvelles licences pour les mêmes constituants selon l’article 10.

9. Acceptation non requise pour obtenir des copies.

Vous n’êtes pas obligé d’accepter cette licence afin de recevoir ou exécuter une copie du Programme. La propagation asservie d’un Travail Couvert qui se produit simplement en conséquence d’une transmission d’égal-à-égal pour recevoir une copie ne nécessite pas l’acceptation. Cependant, rien d’autre que cette Licence ne vous accorde la permission de propager ou modifier un quelconque Travail Couvert. Ces actions enfreignent le Droit d’Auteur si vous n’acceptez pas cette Licence. Par conséquent, en modifiant ou propageant un Travail Couvert,vous indiquez votre acceptation de cette Licence pour agir ainsi.

10. Cession automatique de Licence aux Destinataires et intermédiaires.

Chaque fois que vous acheminez un Travail Couvert, le Destinataire reçoit automatiquement une licence depuis les concédants originaux, pour exécuter, modifier et propager ce travail, suivant les termes de cette Licence. Vous n’êtes pas responsable du renforcement de laconformation des tierces parties avec cette Licence.

Une « transaction d’entité » désigne une transaction qui transfère le contrôle d’une organisation, ou de substantiellement tous ses actifs, ou la subdivision d’une organisation, ou la fusion de plusieurs organisations. Si la propagation d’un Travail Couvert résulte d’une transaction d’entité, chaque partie à cette transaction qui reçoit une copie du travail reçoit aussi les licences pour le travail que le prédécesseur intéressé à cette partie avait ou pourrait donner selon le paragraphe précédent, plus un droit de possession du Source Correspondant de ce travail depuis le prédécesseur intéressé si ce prédécesseur en dispose ou peut l’obtenir par des efforts raisonnables.

Vous ne pouvez imposer aucune restriction avancée dans l’exercice des droits accordés ou affirmés selon cette Licence. Par exemple, vous ne pouvez imposer aucun paiement pour la licence, aucune royaltie, ni aucune autre charge pour l’exercice des droits accordés selon cette Licence ; et vous ne pouvez amorcer aucun litige judiciaire (y compris une réclamation croisée ou contre-réclamation dans un procès) sur l’allégation qu’une revendication de brevet est enfreinte par la réalisation, l’utilisation, la vente, l’offre de vente, oul’importation du Programme ou d’une quelconque portion de celui-ci.

11. Brevets.

Un « contributeur » est un titulaire de Droit d’Auteur (“copyright”) qui autorise l’utilisation selon cette Licence du Programme ou du travail sur lequel le Programme est basé. Le travail ainsi soumis àlicence est appelé la « version contributive » de ce contributeur.

Les « revendications de brevet essentielles » sont toutes les revendications de brevets détenues ou contrôlées par le contributeur, qu’elles soient déjà acquises par lui ou acquises subséquemment, qui pourraient être enfreintes de quelque manière, permises par cette Licence, sur la réalisation, l’utilisation ou la vente de la version contributive de celui-ci. Aux fins de cette définition, le « contrôle » inclue le droit de concéder des sous-licences de brevets d’une manière consistante, nécessaire et suffisante, avec les obligations de cette
Licence.

Chaque contributeur vous accorde une licence de brevet non exclusive, mondiale et libre de toute royaltie, selon les revendications de brevet essentielles, pour réaliser, utiliser, vendre, offrir à la vente, importer et autrement exécuter, modifier et propager les contenus de saversion contributive.

Dans les trois paragraphes suivants, une « licence de brevet » désigne tous les accords ou engagements exprimés, quel que soit le nom que vous lui donnez, de ne pas mettre en vigueur un brevet (telle qu’une permission explicite pour mettre en pratique un brevet, ou un accord pour ne pas poursuivre un Destinataire pour cause de violation de brevet). « Accorder » une telle licence de brevet à une partie signifie conclure un tel accord ou engagement à ne pas faire appliquer le brevetà cette partie.

Si vous acheminez un Travail Couvert, dépendant en connaissance d’une licence de brevet, et si le Source Correspondant du travail n’est pas disponible à quiconque copie, sans frais et suivant les termes de cette Licence, à travers un serveur réseau publiquement acessible ou tout autre moyen immédiatement accessible, alors vous devez soit (1) rendre
la Source Correspondante ainsi disponible, soit (2) vous engager à vous priver pour vous-même du bénéfice de la licence de brevet pour ce travail particulier, soit (3) vous engager, d’une façon consistante avec les obligations de cette Licence, à étendre la licence de brevet aux Destinataires de ce travail. « Dépendant en connaissance » signifie que vous avez effectivement connaissance que, selon la licence de brevet, votre acheminement du Travail Couvert dans un pays, ou l’utilisation du Travail Couvert par votre Destinataire dans un pays, enfreindrait un ou plusieurs brevets identifiables dans ce pays où vous avez des raisons de penser qu’ils sont valides.

Si, conformément à ou en liaison avec une même transaction ou un même arrangement, vous acheminez, ou propagez en procurant un acheminement de, un Travail Couvert et accordez une licence de brevet à l’une des parties recevant le Travail Couvert pour lui permettre d’utiliser, propager, modifier ou acheminer une copie spécifique du Travail Couvert, alors votre accord est automatiquement étendu à tous les Destinataires du Travail Couvert et des travaux basés sur celui-ci.

Une licence de brevet est « discriminatoire » si, dans le champ de sa couverture, elle n’inclut pas un ou plusieurs des droits qui sont spécifiquement accordés selon cette Licence, ou en prohibe l’exercice, ou est conditionnée par le non-exercice d’un ou plusieurs de ces droits. Vous ne pouvez pas acheminer un Travail Couvert si vous êtes partie à un arrangement selon lequel une partie tierce exerçant son activité dans la distribution de logiciels et à laquelle vous effectuez un paiement fondé sur l’étendue de votre activité d’acheminement du travail, et selon lequel la partie tierce accorde, à une quelconque partie qui recevrait depuis vous le Travail Couvert, une licence de brevet discriminatoire (a) en relation avec les copies du Travail Couvert acheminées par vous (ou les copies réalisées à partir de ces copies), ou (b) avant tout destinée et en relation avec des produits spécifiques ou compilations contenant le Travail Couvert, à moins que vous ayez conclu cet arrangement ou que la licence de brevet ait étéaccordée avant le 28 mars 2007.

Rien dans cette Licence ne devrait être interprété comme devant exclure ou limiter toute licence implicite ou d’autres moyens de défense à une infraction qui vous seraient autrement disponible selon la loiapplicable relative aux brevets.

12. Non abandon de la liberté des autres.

Si des conditions vous sont imposées (que ce soit par décision judiciaire, par un accord ou autrement) qui contredisent les conditions de cette Licence, elles ne vous excusent pas des conditions de cette Licence. Si vous ne pouvez pas acheminer un Travail Couvert de façon à satisfaire simulténément vos obligations suivant cette Licence et toutes autres obligations pertinentes, alors en conséquence vous ne pouvez pas du tout l’acheminer. Par exemple, si vous avez un accord sur des termes qui vous obligent à collecter pour le réacheminement des royalties depuis ceux à qui vous acheminez le Programme, la seule façon qui puisse vous permettre de satisfaire à la fois à ces termes et ceux de cette Licence sera de vous abstenir entièrement d’acheminer leProgramme.

13. Utilisation avec la Licence Générale Publique Affero GNU.

Nonobstant toute autre clause de cette Licence, vous avez la permission de lier ou combiner tout Travail Couvert avec un travail placé sous la version 3 de la Licence Générale Publique GNU Affero (“GNU Affero General Public License”) en un seul travail combiné, et d’acheminer le travail résultant. Les termes de cette Licence continueront à s’appliquer à la partie formant un Travail Couvert, mais les obligations spéciales de la Licence Générale Publique GNU Affero, article 13, concernant l’interaction à travers un réseau s’appliqueront à la combinaison en tant que telle.

14. Versions révisées de cette License.

La Free Software Foundation peut publier des versions révisées et/ou nouvelles de la Licence Publique Générale GNU (“GNU General Public License”) de temps en temps. De telles version nouvelles resteront similaires dans l’esprit avec la présente version, mais peuvent différer dans le détail afin de traiter de nouveaux problèmes oupréoccupations.

Chaque version reçoit un numéro de version distinctif. Si le Programme indique qu’une version spécifique de la Licence Publique Générale GNU « ou toute version ultérieure » (“or any later version”) s’applique à celui-ci, vous avez le choix de suivre soit les termes et conditions de cette version numérotée, soit ceux de n’importe quelle version publiée ultérieurement par la Free Software Foundation. Si le Programme n’indique pas une version spécifique de la Licence Publique Générale GNU, vous pouvez choisir l’une quelconque des versions qui ont étépubliées par la Free Software Foundation.

Si le Programme spécifie qu’un intermédiaire peut décider quelles versions futures de la Licence Générale Publique GNU peut être utilisée, la déclaration publique d’acceptation d’une version par cetintermédiaire vous autorise à choisir cette version pour le Programme.

Des versions ultérieures de la licence peuvent vous donner des permissions additionelles ou différentes. Cependant aucune obligation additionelle n’est imposée à l’un des auteurs ou titulaires de Droitd’Auteur du fait de votre choix de suivre une version ultérieure.

15. Déclaration d’absence de garantie.

IL N’Y A AUCUNE GARANTIE POUR LE PROGRAMME, DANS LES LIMITES PERMISES PAR LA LOI APPLICABLE. À MOINS QUE CELA NE SOIT ÉTABLI DIFFÉREMMENT PAR ÉCRIT, LES PROPRIÉTAIRES DE DROITS ET/OU LES AUTRES PARTIES FOURNISSENT LE PROGRAMME « EN L’ÉTAT » SANS GARANTIE D’AUCUNE SORTE, QU’ELLE SOIT EXPRIMÉE OU IMPLICITE, CECI COMPRENANT, SANS SE LIMITER À CELLES-CI, LES GARANTIES IMPLICITES DE COMMERCIALISABILITÉ ET D’ADÉQUATION À UN OBJECTIF PARTICULIER. VOUS ASSUMEZ LE RISQUE ENTIER CONCERNANT LA QUALITÉ ET LES PERFORMANCES DU PROGRAMME. DANS L’ÉVENTUALITÉ OÙ LE PROGRAMME S’AVÉRERAIT DÉFECTUEUX, VOUS ASSUMEZ LES COÛTS DE TOUS LESSERVICES, RÉPARATIONS OU CORRECTIONS NÉCESSAIRES.

16. Limitation de responsabilité.

EN AUCUNE AUTRE CIRCONSTANCE QUE CELLES REQUISES PAR LA LOI APPLICABLE OU ACCORDÉES PAR ÉCRIT, UN TITULAIRE DE DROITS SUR LE PROGRAMME, OU TOUT AUTRE PARTIE QUI MODIFIE OU ACHEMINE LE PROGRAMME COMME PERMIS CI-DESSUS, NE PEUT ÊTRE TENU POUR RESPONSABLE ENVERS VOUS POUR LES DOMMAGES, INCLUANT TOUT DOMMAGE GÉNÉRAL, SPÉCIAL, ACCIDENTEL OU INDUIT SURVENANT PAR SUITE DE L’UTILISATION OU DE L’INCAPACITÉ D’UTILISER LE PROGRAMME (Y COMPRIS, SANS SE LIMITER À CELLES-CI, LA PERTE DE DONNÉES OU L’INEXACTITUDE DES DONNÉES RETOURNÉES OU LES PERTES SUBIES PAR VOUS OU DES PARTIES TIERCES OU L’INCAPACITÉ DU PROGRAMME À FONCTIONNER AVEC TOUT AUTRE PROGRAMME), MÊME SI UN TEL TITULAIRE OU TOUTE AUTRE PARTIEA ÉTÉ AVISÉ DE LA POSSIBILITÉ DE TELS DOMMAGES.

17. Interprétation des sections 15 et 16.

Si la déclaration d’absence de garantie et la limitation de responsabilité fournies ci-dessus ne peuvent prendre effet localement selon leurs termes, les cours de justice qui les examinent doivent appliquer la législation locale qui approche au plus près possible une levée absolue de toute responsabilité civile liée au Programme, à moins qu’une garantie ou assumation de responsabilité accompagne une copie du Programme en échange d’un paiement.

FIN DES TERMES ET CONDITIONS.

Comment appliquer ces termes à vos nouveaux programmes

Si vous développez un nouveau programme et voulez qu’il soit le plus possible utilisable par le public, la meilleure façon d’y parvenir et d’en faire un logiciel libre que chacun peut redistribuer et changersuivant ces termes-ci.

Pour appliquer ces termes, attachez les notices suivantes au programme. Il est plus sûr de les attacher au début de chacun des fichiers sources afin de transporter de façon la plus effective possible l’exclusion de garantie ; et chaque fichier devrait comporter au moins la ligne de réservation de droit (“copyright”) et une indication permettant de savoiroù la notice complète peut être trouvée :

    <one line to give the program's name and a brief idea of what it does.>
    Copyright (C) <year>  <name of author>

    This program is free software: you can redistribute it and/or modify
    it under the terms of the GNU General Public License as published by
    the Free Software Foundation, either version 3 of the License, or
    (at your option) any later version.

    This program is distributed in the hope that it will be useful,
    but WITHOUT ANY WARRANTY; without even the implied warranty of
    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
    GNU General Public License for more details.

    You should have received a copy of the GNU General Public License
    along with this program.  If not, see <http://www.gnu.org/licenses/>.

Ajoutez également les informations permettant de vous contacter par courrier électronique ou postal.

Si le programme produit une interaction sur un terminal, faites lui afficher une courte notice comme celle-ci lors de son démarrage en mode interactif :

    <program>  Copyright (C) <year>  <name of author>

    This program comes with ABSOLUTELY NO WARRANTY; for details type `show w'.
    This is free software, and you are welcome to redistribute it
    under certain conditions; type `show c' for details.

Les commandes hypothétiques “affiche g” and “affiche c” devrait afficher les parties appropriées de la Licence Générale Publique. Bien sûr, les commandes de votre programme peuvent être différentes ; pourune interface graphique, vous pourriez utiliser une « boîte À propos. »

Vous devriez également obtenir de votre employeur (si vous travaillez en tant que programmeur) ou de votre école un « renoncement aux droits de propriété » pour ce programme, si nécessaire. Pour plus d’informations à ce sujet, et comment appliquer la GPL GNU, consultez<http://www.gnu.org/licenses/>.

La Licence Générale Publique GNU ne permet pas d’incorporer votre programme dans des programmes propriétaires. Si votre programme est une bibliothèque de sous-routines, vous pourriez considérer qu’il serait plus utile de permettre de lier des applications propriétaires avec la bibliothèque. Si c’est ce que vous voulez faire, utilisez la Licence Générale Publique Limitée GNU au lieu de cette Licence ; mais d’abord,veuillez lire <http://www.gnu.org/philosophy/why-not-lgpl.html>.


License Agreement

InfraRecorder
License Agreement

GNU GENERAL PUBLIC LICENSE

Version 3, 29 June 2007

Copyright © 2007 Free Software Foundation, Inc. <http://fsf.org/>

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

Preamble

The GNU General Public License is a free, copyleft license for software and other kinds of works.

The licenses for most software and other practical works are designed to take away your freedom to share and change the works. By contrast, the GNU General Public License is intended to guarantee your freedom to share and change all versions of a program--to make sure it remains free software for all its users. We, the Free Software Foundation, use the GNU General Public License for most of our software; it applies also to any other work released this way by its authors. You can apply it to your programs, too.

When we speak of free software, we are referring to freedom, not price. Our General Public Licenses are designed to make sure that you have the freedom to distribute copies of free software (and charge for them if you wish), that you receive source code or can get it if you want it, that you can change the software or use pieces of it in new free programs, and that you know you can do these things.

To protect your rights, we need to prevent others from denying you these rights or asking you to surrender the rights. Therefore, you have certain responsibilities if you distribute copies of the software, or if you modify it: responsibilities to respect the freedom of others.

For example, if you distribute copies of such a program, whether gratis or for a fee, you must pass on to the recipients the same freedoms that you received. You must make sure that they, too, receive or can get the source code. And you must show them these terms so they know their rights.

Developers that use the GNU GPL protect your rights with two steps: (1) assert copyright on the software, and (2) offer you this License giving you legal permission to copy, distribute and/or modify it.

For the developers' and authors' protection, the GPL clearly explains that there is no warranty for this free software. For both users' and authors' sake, the GPL requires that modified versions be marked as changed, so that their problems will not be attributed erroneously to authors of previous versions.

Some devices are designed to deny users access to install or run modified versions of the software inside them, although the manufacturer can do so. This is fundamentally incompatible with the aim of protecting users' freedom to change the software. The systematic pattern of such abuse occurs in the area of products for individuals to use, which is precisely where it is most unacceptable. Therefore, we have designed this version of the GPL to prohibit the practice for those products. If such problems arise substantially in other domains, we stand ready to extend this provision to those domains in future versions of the GPL, as needed to protect the freedom of users.

Finally, every program is threatened constantly by software patents. States should not allow patents to restrict development and use of software on general-purpose computers, but in those that do, we wish to avoid the special danger that patents applied to a free program could make it effectively proprietary. To prevent this, the GPL assures that patents cannot be used to render the program non-free.

The precise terms and conditions for copying, distribution and modification follow.

TERMS AND CONDITIONS

0. Definitions.

“This License” refers to version 3 of the GNU General Public License.

“Copyright” also means copyright-like laws that apply to other kinds of works, such as semiconductor masks.

“The Program” refers to any copyrightable work licensed under this License. Each licensee is addressed as “you”. “Licensees” and “recipients” may be individuals or organizations.

To “modify” a work means to copy from or adapt all or part of the work in a fashion requiring copyright permission, other than the making of an exact copy. The resulting work is called a “modified version” of the earlier work or a work “based on” the earlier work.

A “covered work” means either the unmodified Program or a work based on the Program.

To “propagate” a work means to do anything with it that, without permission, would make you directly or secondarily liable for infringement under applicable copyright law, except executing it on a computer or modifying a private copy. Propagation includes copying, distribution (with or without modification), making available to the public, and in some countries other activities as well.

To “convey” a work means any kind of propagation that enables other parties to make or receive copies. Mere interaction with a user through a computer network, with no transfer of a copy, is not conveying.

An interactive user interface displays “Appropriate Legal Notices” to the extent that it includes a convenient and prominently visible feature that (1) displays an appropriate copyright notice, and (2) tells the user that there is no warranty for the work (except to the extent that warranties are provided), that licensees may convey the work under this License, and how to view a copy of this License. If the interface presents a list of user commands or options, such as a menu, a prominent item in the list meets this criterion.

1. Source Code.

The “source code” for a work means the preferred form of the work for making modifications to it. “Object code” means any non-source form of a work.

A “Standard Interface” means an interface that either is an official standard defined by a recognized standards body, or, in the case of interfaces specified for a particular programming language, one that is widely used among developers working in that language.

The “System Libraries” of an executable work include anything, other than the work as a whole, that (a) is included in the normal form of packaging a Major Component, but which is not part of that Major Component, and (b) serves only to enable use of the work with that Major Component, or to implement a Standard Interface for which an implementation is available to the public in source code form. A “Major Component”, in this context, means a major essential component (kernel, window system, and so on) of the specific operating system (if any) on which the executable work runs, or a compiler used to produce the work, or an object code interpreter used to run it.

The “Corresponding Source” for a work in object code form means all the source code needed to generate, install, and (for an executable work) run the object code and to modify the work, including scripts to control those activities. However, it does not include the work's System Libraries, or general-purpose tools or generally available free programs which are used unmodified in performing those activities but which are not part of the work. For example, Corresponding Source includes interface definition files associated with source files for the work, and the source code for shared libraries and dynamically linked subprograms that the work is specifically designed to require, such as by intimate data communication or control flow between those subprograms and other parts of the work.

The Corresponding Source need not include anything that users can regenerate automatically from other parts of the Corresponding Source.

The Corresponding Source for a work in source code form is that same work.

2. Basic Permissions.

All rights granted under this License are granted for the term of copyright on the Program, and are irrevocable provided the stated conditions are met. This License explicitly affirms your unlimited permission to run the unmodified Program. The output from running a covered work is covered by this License only if the output, given its content, constitutes a covered work. This License acknowledges your rights of fair use or other equivalent, as provided by copyright law.

You may make, run and propagate covered works that you do not convey, without conditions so long as your license otherwise remains in force. You may convey covered works to others for the sole purpose of having them make modifications exclusively for you, or provide you with facilities for running those works, provided that you comply with the terms of this License in conveying all material for which you do not control copyright. Those thus making or running the covered works for you must do so exclusively on your behalf, under your direction and control, on terms that prohibit them from making any copies of your copyrighted material outside their relationship with you.

Conveying under any other circumstances is permitted solely under the conditions stated below. Sublicensing is not allowed; section 10 makes it unnecessary.

3. Protecting Users' Legal Rights From Anti-Circumvention Law.

No covered work shall be deemed part of an effective technological measure under any applicable law fulfilling obligations under article 11 of the WIPO copyright treaty adopted on 20 December 1996, or similar laws prohibiting or restricting circumvention of such measures.

When you convey a covered work, you waive any legal power to forbid circumvention of technological measures to the extent such circumvention is effected by exercising rights under this License with respect to the covered work, and you disclaim any intention to limit operation or modification of the work as a means of enforcing, against the work's users, your or third parties' legal rights to forbid circumvention of technological measures.

4. Conveying Verbatim Copies.

You may convey verbatim copies of the Program's source code as you receive it, in any medium, provided that you conspicuously and appropriately publish on each copy an appropriate copyright notice; keep intact all notices stating that this License and any non-permissive terms added in accord with section 7 apply to the code; keep intact all notices of the absence of any warranty; and give all recipients a copy of this License along with the Program.

You may charge any price or no price for each copy that you convey, and you may offer support or warranty protection for a fee.

5. Conveying Modified Source Versions.

You may convey a work based on the Program, or the modifications to produce it from the Program, in the form of source code under the terms of section 4, provided that you also meet all of these conditions:

  • a) The work must carry prominent notices stating that you modified it, and giving a relevant date.
  • b) The work must carry prominent notices stating that it is released under this License and any conditions added under section 7. This requirement modifies the requirement in section 4 to “keep intact all notices”.
  • c) You must license the entire work, as a whole, under this License to anyone who comes into possession of a copy. This License will therefore apply, along with any applicable section 7 additional terms, to the whole of the work, and all its parts, regardless of how they are packaged. This License gives no permission to license the work in any other way, but it does not invalidate such permission if you have separately received it.
  • d) If the work has interactive user interfaces, each must display Appropriate Legal Notices; however, if the Program has interactive interfaces that do not display Appropriate Legal Notices, your work need not make them do so.

A compilation of a covered work with other separate and independent works, which are not by their nature extensions of the covered work, and which are not combined with it such as to form a larger program, in or on a volume of a storage or distribution medium, is called an “aggregate” if the compilation and its resulting copyright are not used to limit the access or legal rights of the compilation's users beyond what the individual works permit. Inclusion of a covered work in an aggregate does not cause this License to apply to the other parts of the aggregate.

6. Conveying Non-Source Forms.

You may convey a covered work in object code form under the terms of sections 4 and 5, provided that you also convey the machine-readable Corresponding Source under the terms of this License, in one of these ways:

  • a) Convey the object code in, or embodied in, a physical product (including a physical distribution medium), accompanied by the Corresponding Source fixed on a durable physical medium customarily used for software interchange.
  • b) Convey the object code in, or embodied in, a physical product (including a physical distribution medium), accompanied by a written offer, valid for at least three years and valid for as long as you offer spare parts or customer support for that product model, to give anyone who possesses the object code either (1) a copy of the Corresponding Source for all the software in the product that is covered by this License, on a durable physical medium customarily used for software interchange, for a price no more than your reasonable cost of physically performing this conveying of source, or (2) access to copy the Corresponding Source from a network server at no charge.
  • c) Convey individual copies of the object code with a copy of the written offer to provide the Corresponding Source. This alternative is allowed only occasionally and noncommercially, and only if you received the object code with such an offer, in accord with subsection 6b.
  • d) Convey the object code by offering access from a designated place (gratis or for a charge), and offer equivalent access to the Corresponding Source in the same way through the same place at no further charge. You need not require recipients to copy the Corresponding Source along with the object code. If the place to copy the object code is a network server, the Corresponding Source may be on a different server (operated by you or a third party) that supports equivalent copying facilities, provided you maintain clear directions next to the object code saying where to find the Corresponding Source. Regardless of what server hosts the Corresponding Source, you remain obligated to ensure that it is available for as long as needed to satisfy these requirements.
  • e) Convey the object code using peer-to-peer transmission, provided you inform other peers where the object code and Corresponding Source of the work are being offered to the general public at no charge under subsection 6d.

A separable portion of the object code, whose source code is excluded from the Corresponding Source as a System Library, need not be included in conveying the object code work.

A “User Product” is either (1) a “consumer product”, which means any tangible personal property which is normally used for personal, family, or household purposes, or (2) anything designed or sold for incorporation into a dwelling. In determining whether a product is a consumer product, doubtful cases shall be resolved in favor of coverage. For a particular product received by a particular user, “normally used” refers to a typical or common use of that class of product, regardless of the status of the particular user or of the way in which the particular user actually uses, or expects or is expected to use, the product. A product is a consumer product regardless of whether the product has substantial commercial, industrial or non-consumer uses, unless such uses represent the only significant mode of use of the product.

“Installation Information” for a User Product means any methods, procedures, authorization keys, or other information required to install and execute modified versions of a covered work in that User Product from a modified version of its Corresponding Source. The information must suffice to ensure that the continued functioning of the modified object code is in no case prevented or interfered with solely because modification has been made.

If you convey an object code work under this section in, or with, or specifically for use in, a User Product, and the conveying occurs as part of a transaction in which the right of possession and use of the User Product is transferred to the recipient in perpetuity or for a fixed term (regardless of how the transaction is characterized), the Corresponding Source conveyed under this section must be accompanied by the Installation Information. But this requirement does not apply if neither you nor any third party retains the ability to install modified object code on the User Product (for example, the work has been installed in ROM).

The requirement to provide Installation Information does not include a requirement to continue to provide support service, warranty, or updates for a work that has been modified or installed by the recipient, or for the User Product in which it has been modified or installed. Access to a network may be denied when the modification itself materially and adversely affects the operation of the network or violates the rules and protocols for communication across the network.

Corresponding Source conveyed, and Installation Information provided, in accord with this section must be in a format that is publicly documented (and with an implementation available to the public in source code form), and must require no special password or key for unpacking, reading or copying.

7. Additional Terms.

“Additional permissions” are terms that supplement the terms of this License by making exceptions from one or more of its conditions. Additional permissions that are applicable to the entire Program shall be treated as though they were included in this License, to the extent that they are valid under applicable law. If additional permissions apply only to part of the Program, that part may be used separately under those permissions, but the entire Program remains governed by this License without regard to the additional permissions.

When you convey a copy of a covered work, you may at your option remove any additional permissions from that copy, or from any part of it. (Additional permissions may be written to require their own removal in certain cases when you modify the work.) You may place additional permissions on material, added by you to a covered work, for which you have or can give appropriate copyright permission.

Notwithstanding any other provision of this License, for material you add to a covered work, you may (if authorized by the copyright holders of that material) supplement the terms of this License with terms:

  • a) Disclaiming warranty or limiting liability differently from the terms of sections 15 and 16 of this License; or
  • b) Requiring preservation of specified reasonable legal notices or author attributions in that material or in the Appropriate Legal Notices displayed by works containing it; or
  • c) Prohibiting misrepresentation of the origin of that material, or requiring that modified versions of such material be marked in reasonable ways as different from the original version; or
  • d) Limiting the use for publicity purposes of names of licensors or authors of the material; or
  • e) Declining to grant rights under trademark law for use of some trade names, trademarks, or service marks; or
  • f) Requiring indemnification of licensors and authors of that material by anyone who conveys the material (or modified versions of it) with contractual assumptions of liability to the recipient, for any liability that these contractual assumptions directly impose on those licensors and authors.

All other non-permissive additional terms are considered “further restrictions” within the meaning of section 10. If the Program as you received it, or any part of it, contains a notice stating that it is governed by this License along with a term that is a further restriction, you may remove that term. If a license document contains a further restriction but permits relicensing or conveying under this License, you may add to a covered work material governed by the terms of that license document, provided that the further restriction does not survive such relicensing or conveying.

If you add terms to a covered work in accord with this section, you must place, in the relevant source files, a statement of the additional terms that apply to those files, or a notice indicating where to find the applicable terms.

Additional terms, permissive or non-permissive, may be stated in the form of a separately written license, or stated as exceptions; the above requirements apply either way.

8. Termination.

You may not propagate or modify a covered work except as expressly provided under this License. Any attempt otherwise to propagate or modify it is void, and will automatically terminate your rights under this License (including any patent licenses granted under the third paragraph of section 11).

However, if you cease all violation of this License, then your license from a particular copyright holder is reinstated (a) provisionally, unless and until the copyright holder explicitly and finally terminates your license, and (b) permanently, if the copyright holder fails to notify you of the violation by some reasonable means prior to 60 days after the cessation.

Moreover, your license from a particular copyright holder is reinstated permanently if the copyright holder notifies you of the violation by some reasonable means, this is the first time you have received notice of violation of this License (for any work) from that copyright holder, and you cure the violation prior to 30 days after your receipt of the notice.

Termination of your rights under this section does not terminate the licenses of parties who have received copies or rights from you under this License. If your rights have been terminated and not permanently reinstated, you do not qualify to receive new licenses for the same material under section 10.

9. Acceptance Not Required for Having Copies.

You are not required to accept this License in order to receive or run a copy of the Program. Ancillary propagation of a covered work occurring solely as a consequence of using peer-to-peer transmission to receive a copy likewise does not require acceptance. However, nothing other than this License grants you permission to propagate or modify any covered work. These actions infringe copyright if you do not accept this License. Therefore, by modifying or propagating a covered work, you indicate your acceptance of this License to do so.

10. Automatic Licensing of Downstream Recipients.

Each time you convey a covered work, the recipient automatically receives a license from the original licensors, to run, modify and propagate that work, subject to this License. You are not responsible for enforcing compliance by third parties with this License.

An “entity transaction” is a transaction transferring control of an organization, or substantially all assets of one, or subdividing an organization, or merging organizations. If propagation of a covered work results from an entity transaction, each party to that transaction who receives a copy of the work also receives whatever licenses to the work the party's predecessor in interest had or could give under the previous paragraph, plus a right to possession of the Corresponding Source of the work from the predecessor in interest, if the predecessor has it or can get it with reasonable efforts.

You may not impose any further restrictions on the exercise of the rights granted or affirmed under this License. For example, you may not impose a license fee, royalty, or other charge for exercise of rights granted under this License, and you may not initiate litigation (including a cross-claim or counterclaim in a lawsuit) alleging that any patent claim is infringed by making, using, selling, offering for sale, or importing the Program or any portion of it.

11. Patents.

A “contributor” is a copyright holder who authorizes use under this License of the Program or a work on which the Program is based. The work thus licensed is called the contributor's “contributor version”.

A contributor's “essential patent claims” are all patent claims owned or controlled by the contributor, whether already acquired or hereafter acquired, that would be infringed by some manner, permitted by this License, of making, using, or selling its contributor version, but do not include claims that would be infringed only as a consequence of further modification of the contributor version. For purposes of this definition, “control” includes the right to grant patent sublicenses in a manner consistent with the requirements of this License.

Each contributor grants you a non-exclusive, worldwide, royalty-free patent license under the contributor's essential patent claims, to make, use, sell, offer for sale, import and otherwise run, modify and propagate the contents of its contributor version.

In the following three paragraphs, a “patent license” is any express agreement or commitment, however denominated, not to enforce a patent (such as an express permission to practice a patent or covenant not to sue for patent infringement). To “grant” such a patent license to a party means to make such an agreement or commitment not to enforce a patent against the party.

If you convey a covered work, knowingly relying on a patent license, and the Corresponding Source of the work is not available for anyone to copy, free of charge and under the terms of this License, through a publicly available network server or other readily accessible means, then you must either (1) cause the Corresponding Source to be so available, or (2) arrange to deprive yourself of the benefit of the patent license for this particular work, or (3) arrange, in a manner consistent with the requirements of this License, to extend the patent license to downstream recipients. “Knowingly relying” means you have actual knowledge that, but for the patent license, your conveying the covered work in a country, or your recipient's use of the covered work in a country, would infringe one or more identifiable patents in that country that you have reason to believe are valid.

If, pursuant to or in connection with a single transaction or arrangement, you convey, or propagate by procuring conveyance of, a covered work, and grant a patent license to some of the parties receiving the covered work authorizing them to use, propagate, modify or convey a specific copy of the covered work, then the patent license you grant is automatically extended to all recipients of the covered work and works based on it.

A patent license is “discriminatory” if it does not include within the scope of its coverage, prohibits the exercise of, or is conditioned on the non-exercise of one or more of the rights that are specifically granted under this License. You may not convey a covered work if you are a party to an arrangement with a third party that is in the business of distributing software, under which you make payment to the third party based on the extent of your activity of conveying the work, and under which the third party grants, to any of the parties who would receive the covered work from you, a discriminatory patent license (a) in connection with copies of the covered work conveyed by you (or copies made from those copies), or (b) primarily for and in connection with specific products or compilations that contain the covered work, unless you entered into that arrangement, or that patent license was granted, prior to 28 March 2007.

Nothing in this License shall be construed as excluding or limiting any implied license or other defenses to infringement that may otherwise be available to you under applicable patent law.

12. No Surrender of Others' Freedom.

If conditions are imposed on you (whether by court order, agreement or otherwise) that contradict the conditions of this License, they do not excuse you from the conditions of this License. If you cannot convey a covered work so as to satisfy simultaneously your obligations under this License and any other pertinent obligations, then as a consequence you may not convey it at all. For example, if you agree to terms that obligate you to collect a royalty for further conveying from those to whom you convey the Program, the only way you could satisfy both those terms and this License would be to refrain entirely from conveying the Program.

13. Use with the GNU Affero General Public License.

Notwithstanding any other provision of this License, you have permission to link or combine any covered work with a work licensed under version 3 of the GNU Affero General Public License into a single combined work, and to convey the resulting work. The terms of this License will continue to apply to the part which is the covered work, but the special requirements of the GNU Affero General Public License, section 13, concerning interaction through a network will apply to the combination as such.

14. Revised Versions of this License.

The Free Software Foundation may publish revised and/or new versions of the GNU General Public License from time to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Program specifies that a certain numbered version of the GNU General Public License “or any later version” applies to it, you have the option of following the terms and conditions either of that numbered version or of any later version published by the Free Software Foundation. If the Program does not specify a version number of the GNU General Public License, you may choose any version ever published by the Free Software Foundation.

If the Program specifies that a proxy can decide which future versions of the GNU General Public License can be used, that proxy's public statement of acceptance of a version permanently authorizes you to choose that version for the Program.

Later license versions may give you additional or different permissions. However, no additional obligations are imposed on any author or copyright holder as a result of your choosing to follow a later version.

15. Disclaimer of Warranty.

THERE IS NO WARRANTY FOR THE PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE PROGRAM “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE PROGRAM PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

16. Limitation of Liability.

IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MODIFIES AND/OR CONVEYS THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER PROGRAMS), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

17. Interpretation of Sections 15 and 16.

If the disclaimer of warranty and limitation of liability provided above cannot be given local legal effect according to their terms, reviewing courts shall apply local law that most closely approximates an absolute waiver of all civil liability in connection with the Program, unless a warranty or assumption of liability accompanies a copy of the Program in return for a fee.

END OF TERMS AND CONDITIONS

How to Apply These Terms to Your New Programs

If you develop a new program, and you want it to be of the greatest possible use to the public, the best way to achieve this is to make it free software which everyone can redistribute and change under these terms.

To do so, attach the following notices to the program. It is safest to attach them to the start of each source file to most effectively state the exclusion of warranty; and each file should have at least the “copyright” line and a pointer to where the full notice is found.

    <one line to give the program's name and a brief idea of what it does.>
    Copyright (C) <year>  <name of author>

    This program is free software: you can redistribute it and/or modify
    it under the terms of the GNU General Public License as published by
    the Free Software Foundation, either version 3 of the License, or
    (at your option) any later version.

    This program is distributed in the hope that it will be useful,
    but WITHOUT ANY WARRANTY; without even the implied warranty of
    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
    GNU General Public License for more details.

    You should have received a copy of the GNU General Public License
    along with this program.  If not, see <http://www.gnu.org/licenses/>.

Also add information on how to contact you by electronic and paper mail.

If the program does terminal interaction, make it output a short notice like this when it starts in an interactive mode:

    <program>  Copyright (C) <year>  <name of author>

    This program comes with ABSOLUTELY NO WARRANTY; for details type `show w'.
    This is free software, and you are welcome to redistribute it
    under certain conditions; type `show c' for details.

The hypothetical commands `show w' and `show c' should show the appropriate parts of the General Public License. Of course, your program's commands might be different; for a GUI interface, you would use an “about box”.

You should also get your employer (if you work as a programmer) or school, if any, to sign a “copyright disclaimer” for the program, if necessary. For more information on this, and how to apply and follow the GNU GPL, see <http://www.gnu.org/licenses/>.

The GNU General Public License does not permit incorporating your program into proprietary programs. If your program is a subroutine library, you may consider it more useful to permit linking proprietary applications with the library. If this is what you want to do, use the GNU Lesser General Public License instead of this License. But first, please read <http://www.gnu.org/philosophy/why-not-lgpl.html>.


Configuration requise

InfraRecorder
Configuration requise

La configuration requise pour InfraRecorder est la suivante:

  • Windows 98 avec Internet Explorer 5.0 ou plus récent.
  • 32 Mo de RAM.
  • 8.1 Mo disponible sur le disque dur.


Démarrage rapide

InfraRecorder
Démarrage rapide

Comment faire ?

Premier projet
Disques multi-sessions
Copie de disques de données
Copie de disques audios
Effacer des disques ré-inscriptibles
Les informations du disque
Configurer les périphériques


Copyright

InfraRecorder
Copyright

InfraRecorder copyright © 2006-2009 Christian Kindahl.

InfraRecorder fonctionne en co-operation avec les logiciels suivant:

  • cdrecord © 1995-2006 Jörg Schilling.
  • readcd © 1987, 1995-2006 Jörg Schilling.
  • cdda2wav par Project MODE, Fraunhofer Institut für integrierte Schaltungen.


Accords

InfraRecorder
Accords

InfraRecorder utilise des icônes et des des travaux dérivés issus du Tango Icon Project. Les travaux dérivés basés sur les icônes Tango peuvent être téléchargés séparément (sous Creative Commons Attribution Share-Alike license) à partir du site web officiel de InfraRecorder.


Quoi de neuf

InfraRecorder
Quoi de neuf ?

Version 0.50.0.0

  • Relaxed default project ISO9660 settings.
  • Made progress dialogs resizable for easier reading.
  • Added wait cursors to time consuming operations.
  • Fixed bug causing failed operations to sometimes be reporeted as successful.
  • Fixed bug causing an error when verifying discs containing single character file or directory names.
  • Updated cdrtools to version 2.01.01a61.
  • Added support for displaying BluRay and HD-DVD capabilities.
  • Displayed OK button problem should now be gone.
  • Greatly improved device detection speed, devices are now always probed at startup.
  • Fixed a bug preventing boot images from being removed from projects.
  • Updated InfraRecorder projects not to store file size information that potentially could cause write errors.
  • Added safety net preventing non-recoverable read errors to affect integrity of other files during recording operation.
  • Updated InfraRecorder to lock files on hard drive during file system creation in order to avoid inconsistency errors.
  • Added support for importing data from file lists like M3U.
  • Added command line options for selecting default project and media type.
  • Fixed a bug causing projects opened by association not to be loaded if welcome screen was enabled.
  • Added support for using Ctrl+A in the track secion to select all tracks.
  • The drive letter is now displayed with the name of all CD/DVD devices.
  • Renamed disc fixation to disc closing.
  • Fixed bugs related to drive letter detection.

Version 0.46.2.0

  • Fixed a bug causing the disc file system creation process to hang on some systems (for real this time).
  • Fixed a bug causing a custom temporary directory not to be used.
  • Fixed a start-up maximization bug.

Version 0.46.1.0

  • Fixed a bug causing the disc file system creation process to hang on some systems.

Version 0.46.0.0

  • Minor bugfixes and updates.
  • Added support for recording multiple copies.
  • Added a welcome screen to the InfraRecorder main application and removed the express application.
  • Solved a bug causing the OK button not to be enabled after erasing or formatting a disc.
  • Moved all source code to GPL version 3.
  • Removed cdrtools binaries in favor of cdrkit binaries.
  • Improved device detection routines, there should not be any more problems with wrongly detected drive letters.
  • Included an Indonesian translation, thanks to Andhika Padmawan!
  • Included a Chuvash translation, thanks to Vladimir Kozhevnikov!
  • Fixed a bug causing the express application and shell extension not to be translated.
  • Updated the portable version of InfraRecorder to store its log files in the program directory instead of in the the application data folder.

Version 0.45.0.0

  • Updated cdrtools to version 2.01.01a38.
  • Fixed a bug making InfraRecorder crash when trying to move a folder to itself.
  • Fixed a bug causing the wrong folder to be opened when double-clicking in the project list view when a project contained folders with identical names.
  • Fixed a bug causing the focus not to be returned to the OK button in the progress dialog after performing an operation.
  • Fixed icon rendering error on Windows XP and newer where display depth is lower than 32-bits.
  • Changed the option to verify the device configuration at start up to be enabled by default.
  • Added support for associating InfraRecorder with disc images.
  • Updated the some of the dialog windows to be minimizable and visible on the task bar when launced by an external application (like irExpress).
  • Fixed a bug causing incorrect file names to be used when verifying recorded discs.
  • Added functionallity to rename and remove files from imported sessions.
  • Added support for selecting which multi-session track to import.
  • When trying to record to a non-empty rewritable disc, InfraRecorder now asks if the disc should be erased.
  • When performing an operation the progress is now also displayed in the taskbar.
  • Reduced memory usage when dealing with projects.
  • Fixed a bug making it impossible to open saved projects containing no files.
  • Included a Thai translation, thanks to Prasit Kaephukhieo!
  • Improved compatibility with the ISO9660 standard.
  • Added support for creating UDF-only file systems.
  • Added support for Unicode files names in Joliet extension and UDF file system.
  • Added support for fragmented files in ISO9660 level 3. Files larger than 4 GiB can now be recorded to an ISO9660 file system.
  • Removed mkisofs and isoinfo dependencies.
  • Fixed some bugs related to importing disc sessions.
  • Added properties menu item when right-clicking on the project tree root node.
  • Added proper flagging of hidden files in the disc file system.
  • Changed the default write method for multi-session projects to TAO.
  • Fixed a bug causing InfraRecorder to crash when renaming project files to include slash or backslash characters.
  • Added the .img extension to the list of supported disc image extensions.
  • A few cosmetic changes.
  • Included an Arabic translation, thanks to Circoficus!
  • Included a Greek translation, thanks to ÓôáìÜôéïò Ç. ÓôáìáôÝëëïò!

Version 0.44.1.0

  • Introduced alternate ways of fetching recorder write speeds. This solves the "disabled OK button problem".
  • Added support for reloading laptop drives (drives that can not automatically load themselves) before starting the disc verification process.
  • Corrected a version display error in the log system.

Version 0.44.0.0

  • Added a warning message when disabling disc fixation since some users believes that this will create a multi-session disc.
  • It's now possible to perform a disc copy using the same device as source and target.
  • Updated drive speed detection routines, it should now detect correct speeds depeding on the inserted media.
  • Improved the media removal/insertion auto detection routines.
  • Added support for switching through the controls of the main view using the tab key.
  • Fixed a bug causing InfraRecorder to crash on Windows 9x systems when changing folder in the explorer view.
  • Added menu items for selecting all files and inverting the file selection.
  • Fixed a bug causing negative progress to be displayed in some cases.
  • Updated InfraRecorder to correctly maximize on startup, if closed maximized.
  • Added a website button to the about window.
  • Fixed a project file rename bug.
  • Made the toolbar customizable in several ways.
  • Improved project file handling, no duplicate files or folders are allowed.
  • The program configuration is now stored in the application data folder. A new portable version of InfraRecorder has been created where data is stored in the program folder.
  • Greatly improved drag and drop functionality.
  • Included a Norwegian translation, thanks to Karol Ptasinski!
  • Updated the help file with index and search capabilities.
  • Fixed a bug causing InfraRecorder to try to verify files that where imported from previous sessions.
  • Fixed a bug causing the disc to be ejected (if requested) before starting the disc verification process.
  • Fixed a bug causing incompatibility with Windows 9x systems due to a function call to SHGetFolderPathA.

Version 0.43.1.0

  • Updated the cdrtools to version 2.01.01a26.
  • Included a Finnish translation, thanks to Rami Aalto!
  • Removed the error message related to ckEffects.exe.
  • Improved the erase feature with support for more recorders.
  • Fixed a bug causing the size and position of the main window not to be remembered.
  • Fixed a bug causing the explorer view to turn white when double-clicking on a folder in the explorer list view (Windows XP only).
  • Improved the program log functionality.
  • Fixed a bug making it impossible to import sessions from certain disc types.
  • Improved the explorer view performance. Expanding anything under "My Computer" in the tree could on some systems result in a long delay because of slow queries to floppy drives.

Version 0.43.0.0

  • Fixed a bug raising an exception when re-ordering audio tracks.
  • Added a smoke effect when writing to a disc (requires Windows Vista Aero to be enabled).
  • Fixed a few bugs causing wrong disc information to be shown in the disc information window.
  • Various adaptations for Windows Vista.
  • Added support for dropping files into the project tree view.
  • Completely rewritten disc erase/format code. Improved DVD±RW and DVD-RAM support.
  • Included a Catalan translation, thanks to Josep Lluís Amador Teruel!
  • Included a Galician translation, thanks to Xesús Estévez!
  • Fixed a bug causing InfraRecorder to have invalid window coordinates closed while minimized.
  • Included a Romanian translation, thanks to Nicolae Crefelean!
  • Removed the Visual C++ 8 DLL dependencies from the shell extension.
  • Included a Hungarian translation, thanks to Tibor Sárkány!
  • Included a Hebrew translation, thanks to Shemesh!
  • Included a Danish translation, thanks to Patrick Fust!
  • Fixed a bug causing all internal SCSI commands not to be executed in the x64 build of InfraRecorder.

Version 0.42.1.0

  • The MSI installer used for the x64 release now creates the start-menu shortcuts in a subfolder.
  • Fixed a bug causing InfraRecorder to crash when cdrecord reported recording on a track-number higher than the number of tracks to be recorded.
  • Removed the Visual C++ 8 DLL dependencies from the irWave codec.
  • Fixed a bug causing stack corruption when using the irWMA codec.

Version 0.42.0.0

  • Available as 64-bit (x64) build.
  • Created a completely new Wave codec to remove the libsndfile dependency and add support for the x64 compiler.
  • Modifed the translation system to allow translated controls to automatically resize and move its neightbours when needed.
  • Various changes for Windows Vista compatibility.
  • Modified the WMA codec so it doesn't raise an error message when it fails to load (if Windows Media Player not installed).
  • Included a Japanese translation, thanks to Nardog!
  • Fixed a bug causing DVD media to always be recorded at maximum speed.
  • Included a Korean translation, thanks to Jung Jin-ho!
  • Included a Bulgarian translation, thanks to Iliyan Popov!
  • Separated data DVD from data CD projects.
  • Added support for omiting version numbers from ISO9660 file names.
  • Added support for using Rock Ridge extensions without using the Joliet file name extension.
  • Fixed a bug causing the write speed not to be properly reported on some recorders.
  • Added support for column sorting.
  • Added support for rearranging audio tracks by drag and drop.
  • Included a Serbian (Cyrillic and Latin) translation, thanks to ozzii!
  • Added support for automatically verifying a disc after it has been recorded.
  • Made the labels on the progress dialog double buffered to avoid flickering.
  • Fixed a bug causing the cp1250 code page not to be properly detected on Czech systems.
  • Added support for creating DVD-Video projects.
  • Included a Slovak translation, thanks to Marek!
  • Fixed a bug causing problems when importing certain seasons from multi-session discs.
  • Fixed a bug causing project UDF-settings not to be properly reset when creating a new project.
  • Fixed a bug causing error messages not to be properly displayed when recording custom projects on the fly.
  • Included a Chinese (Traditional) translation, thanks to Charlie!

Version 0.41.0.0

  • Fixed a bug causing the space meter to display inaccurate file sizes on audio files in mixed-mode projects.
  • Due to limitations in the Microsoft Windows 9x Unicode Layer, a non-unicode version of InfraRecorder is released separateley.
  • Added support for disabling the error message that occurs when a codec fails to load.
  • Added support for generating DVD-Video compliant filesystems.
  • Added support for UDF.
  • Added support for creating bootable data discs.
  • Fixed a major bug preventing some projects from beeing properly loaded.
  • Included a Bosnian translation, thanks to Asim Husanovic!
  • Added an option to change the detected write speed of a recorder.
  • Changed the recorder speed management to now allow a larger number of write speeds below the maximum speed.
  • Added write method information to the advanced device details.
  • Fixed a bug causing a wrong character set to be detected on systems using code page 1251.
  • Fixed a bug causing bogus unix file permissions to be set when recording custom projects using the Joliet name extension.
  • Improved the project space meter.
  • Added support for recording custom projects on the fly.
  • Fixed a bug causing a temporary file not to be removed when copying a disc.
  • Added support for disabling the unsupported character set error message.
  • Fixed a bug causing the space meter tooltip to display the size information in bytes instead of minutes when dealing with audio projects.
  • Included a Slovenian translation, thanks to Frani Žižek!
  • Included a Ukrainian translation and manual, thanks to Serhij Dubyk!
  • The advanced device properties list now correctly displays titletip when a feature description is to long to be fully displayed.
  • Fixed a bug causing empty directories to be ignored when creating and recording custom projects.
  • Fixed a bug causing files that has equal characters in the file name to raise an error when creating a disc image.
  • Included a Portuguese (Brazilian) translation, thanks to Éder Silva!
  • Included a Chinese (Simplified) translation, thanks to DouDeHou!
  • Added more read options (ignore read errors, read sub-channel data and TOC, read speed).
  • Added support for disc cloning.
  • Added support for changing the FIFO buffer size.
  • Added support for ISO level 4 which among many thigs allows directory nesting to be deeper than eight levels.

Version 0.40.0.0

  • Included a Czech translation, thanks to khagaroth!
  • Improved DVD-support (official cdrtools has DVD support since version 2.01.01a09).
  • Simulation mode now works when recording to DVDs.
  • Support for blanking DVD+RW media (currently only with Ricoh based drives).
  • The size and position of the main InfraRecorder window is now remembered and restored each startup.
  • Included a Basque translation, thanks to David García-Abad!
  • Added support for encoding audio tracks to Ogg, WMA and MP3 (separate package due to patent issue).
  • Fixed a bug causing the wrong tracks to be displayed when scanning a disc for errors.
  • Added support for decoding MP3, Ogg and WMA audio.
  • Included a German manual, thanks to CE4!
  • Included an Italian translation, thanks to Lorenzo Festa!
  • Fixed bug with message boxes, they should now be modal.
  • Added support for translated manuals.
  • Changed the default simulation value to off.
  • Added an option for changing the temporary folder.
  • Added help documentation on how to make the InfraRecorder installer perform unattended installations.
  • The installer now adds an entry to Add/Remove Programs.
  • Added support for selecting installation language on unattended installations.
  • Included a Russian translation and manual, thanks to Roman Starikh!
  • Included a German translation, thanks to Thomas Bigler!
  • Included a Polish translation, thanks to DJD!
  • Included a Turkish translation, thanks to Fatma Akarslan!
  • Included a Croatian translation, thanks to Tibor Keser!
  • Included a Dutch translation, thanks to Patrick!

Version 0.31.0.0

  • Included a Portuguese translation, thanks to Cesar Baptista!
  • Included a Spanish translation, thanks to Eduardo Leon!
  • Increased the height of all comboboxes in the GUI to prevent unnecessary scrolling.
  • Fixed some GUI glitches causing black and purple backgrounds on some graphics (only affected systems older than Windows XP).
  • Added a tooltip to the space meter which displays the project size.
  • Added support for pasting files from Windows Explorer into a project.
  • Fixed a bug allowing multiple sessions to imported to a project.

Version 0.30.0.83

  • Fixed a bug (static linking to UpdateLayeredWindow in user32.dll) causing incompatibility with Windows 9x systems.

Version 0.30.0.82 (Beta 2)

  • Added DVD support by patching cdrecord (WARNING: Simulation mode is known not to work when burning DVDs).
  • Included a French translation, thanks to Pierre-Jean Coudert!
  • Changed the default write method to SAO because of DVD compatibility.
  • Updated the installer with extra options and multi-language support.
  • Added a couple of new translateable strings for the progress log output.
  • Made some directory layout changes to the CVS.


Installation

InfraRecorder
Installation

Le logiciel d'installation (installeur) de InfraRecorder support différentes options pour des installations spécifiques. Les paramètres suivants peuvent être passés à l'installeur:

/S
Execute l'installeur (ou désinstalleur) en mode silencieux. Toutes les choix utilisateurs se feront par défaut à moins de définir une option supplémentaire.

/LANGUAGE=<langue>
Défini la langue qui doit être utilisée par InfraRecorder. Par exemple: "irsetup.exe /S /LANGUAGE=swedish" installera InfraRecorder en mode silencieux avec la langue Suédoise.


Foire aux Questions

InfraRecorder
Foire aux Questions

Pour une liste de questions plus à jour, visitez le site http://infrarecorder.org.

InfraRecorder ne reconnait pas mon graveur. Comment puis-je résoudre le problème ?
Il s'agit bien souvent d'un problème de permission. Par défaut, InfraRecorder utilise une interface appelée SPTI pour accéder aux péripharique de gravure. Avec Windows 200, XP et 2003, une permission administrateur est requise pour accéder aux périphériques SPTI.

Si vous souhaitez autoriser aux comptes restreints l'accès au périphériques SPTI, vous devez procéder comme suit en étant administrateur :

  1. A partir du menu "Démarrer" appelez la commande "Executer".
  2. Tapez la commande "secpol.msc" (sans les guillemets) et cliquez sur le bouton OK.
  3. Naviguez dans "Stratégies locale" puis "Options de sécurité".
  4. Changez la stratégie "Périphérique : ne permettre l'accès au CD-ROM qu'aux utilisateurs connectés localement" de "Désactivé" en "Activé".

Notez que certaines versions de Windows (comme Windows XP par exemple) n'ont pas de gestionnaire de stratégie "secpol.msc". Dans ce cas, vous devrez procéder comme suit en tant qu'administrateur :

  1. A partir du menu "Démarrer" appelez la commande "Executer".
  2. Tapez la commande "regedit" (sans les guillemets) et cliquez sur le bouton OK.
  3. Naviguez au sein de l'arborescence "HKEY_LOCAL_MACHINE", "SOFTWARE", "Microsoft", "Windows NT", "CurrentVersion" et "Winlogon"
  4. Double cliquez sur la valeur de type REG_SZ appelée "allocatecdroms", puis rentrez la valeur "1" (sans les guillemets). with the value "1" (without the quotes). Si la valeur n'existe pas, vous pouvez la créer en cliquant droit, et en suivant le menu "Nouveau>Valeur chaîne" avec le nom "allocatecdroms", et la valeur "1".


Premier projet

Comment faire ?, Travail en projet.
Premier projet

Cette section va vous aider à démarrer avec votre premier projet CD/DVD de donnée personnalisées. InfraRecorder supporte actuellement quatre types de projets.

Les projets CD/DVD de données sont utilisés pour créer contenant des fichiers et des répertoires (en utilisant le système de fichiers ISO9660) qui peut être exploité par presque tout ordinateur. Les disques de données ne peuvent contenir autant de données que les disques audios par secteurs car le système de fichier stocke également des données de contrôle et de corrections d'erreur supplémentaires. De ce fait, les disques de données peuvent être gravés à une vitesse plus élevées sans perte de données ou de qualité. Les disques de données peuvent être gravés en plusieurs fois, autorisant ainsi l'ajout de données sur un CD/DVD déjà gravé. Référez-vous à cette section pour en savoir plus sur ce sujet.

Les projets CD Audio sont utilisés pour créer des disque audios qui peuvent être lu par n'importe quelle platine CD de salon (ou d'ordinateur). Les CD audios doivent normalement être gravé à une vitesse plus lente que les CD de données car ils ne contiennent pas d'informations de contrôle ou de correction d'erreurs.

Les projets CD en mode mixte sont utilisé pour créer des CD qui contiennent des données sur leur première piste avec les mêmes fonctionnalités qu'un CD de données, suivi par des piste audios.Un CD mixte sera lu par n'importe quelle platine de salon, mais la première piste (celle des données) ne sera que du bruit . Les pistes audios seront jouées normalement.

Les projets DVD vidéo sont utilisés pour créer des DVD qui pourront être lu sur une platine DVD de salon. Des restrictions d'ordre matérielles peuvent cependant empêcher la platine de lire un DVD gravé suivant le type de DVD gravé (+R, +RW, -R, -RW). Renseignez vous sur votre platine de salon avant de graver un DVD vidéo.

Pour créer un nouveau projet, utilisez le menu:
Fichier [image] Nouveau Projet [image] <sélectionnez le type de projet que vous souhaitez créer>
Pour ouvrir un projet existant, utilisez le menu:
File [image] Ouvrir un project...
ou le bouton de la barre d'outils:

Un projet InfraRecorder peut être directement gravé sur un CD/DVD physique, ou être enregisté dans un fichier image disque. Une image disque est un fichier contenant toutes les données ajoutées au projet (sauf les pistes audios dans le cas d'un projet audio ou projet mode mixte). Une image disque peut être gravées sur un CD/DVD plus tard. Voir cette section pour plus d'information.

Pour graver votre projet sur un CD/DVD, vous pouvez utiliser le menu:
Actions [image] Graver la compilation [image] D'un disque compact...
ou le bouton de la barre d'outils:

Une description détaillée des options disponible apparaît dans cette section.

Environment

General

La barre d'outil de la Vue Explorateur permet de naviguer dans la vue, et d'ajouter au projet les fichiers ou dossier sélectionnés dans la liste.
La barre d'outil de la vue Organisation du disque est utilisée pour gérer le projet et naviguer dans le projet.

Gestion des fichiers

Le menu Edition est utilisé pour la gestion des fichiers du projet.
Les options disponibles dans le menu d'édition (ci-dessus) peuvent être appelé à partir de la vue de l'explorateur par appel d'un menu contextuel à l'aide d'un clic droit dans la vue. Par exemple, si vous faites un clic droit sur un dossier, ce menu apparaîtra:
Si vous ajoutez à votre projet plus de données que le média sélectionné ne peut en contenir, l'indicateur d'espace en bas de la vue passera au rouge:
L'indicateur d'espace passera à l'orange si la somme des données du projet excède la taille officielle du média, mais pourront probablement tenir si l'option Autoriser l'overburning est activée:

Vous pouvez changer la taille de l'indicateur afin de correspondre au disque vierge sur lequel vous allez graver votre projet. Pour cela, faites un clic droit sur l'indicateur, et sélectionnez le type de média approprié.

Gestion de fichiers

Ajout de fichiers

Il y a différents moyens d'ajouter des fichiers à votre projet. Vous pouvez faire un glisser-déposer depuis la vue explorateur ou depuis l'explorateur Windows vers la vue organisation du disque. Vous pouvez également naviguer dans la vue explorateur et sélectionner les fichiers que vous souhaitez ajouter à votre projet.

Lorsque les fichiers désirés sont sélectionnés, vous pouvez utiliser le menu:
Edition [image] Ajouter [image] Sélectionné
ou le bouton de la barre d'outil de la vue explorateur:

Vous pouvez également naviguer dans la vue explorateur sur un dossier, et rapidement ajouter tous les dossiers et fichiers contenus dans ce dossier à votre projet.

Pour ajouter tous les fichiers et dossiers dans la vue explorateur active, utilisez le menu:
Edition [image] Ajouter [image] Tout
ou le bouton de la barre d'outil de la vue explorateur:

Supprimer des fichiers

Il y a plusieurs façons de supprimer des fichiers et des dossiers de votre projet. Une façon consiste à sélectionner les fichiers et dossiers dans la vue organisation du disque et appuyer sur le touche "suppr" de votre clavier. Vous pouvez également utiliser le menu ou le bouton de la barre d'outil:

Pour supprimer les fichiers sélectionnés en utilisant le menu:
Edition [image] Supprimer
ou le bouton de la barre d'outil de la vue organisation du disque:

Autres opérations

Pour renommer un fichier ou un dossier sélectionné, utilisez le menu:
Edition [image] Renommer
ou le bouton de la barre d'outil de la vue organisation du disque:
Pour ajouter un dossier vide à votre projet, utilisez le menu:
Edition [image] Nouveau Dossier
ou le bouton de la barre d'outil de la vue organisation du disque:


Disques multi-sessions

Comment faire ?, Travail en projet.
Disques multi-sessions

Un disque multi-session est un disque contenant de multiple gravures. Un disque multi-session peut être graver en plusieurs étapes en ne gravant qu'une session à la fois.

Création d'un nouveau disque multi-session

La création d'un disque multi-session est simple. Tout d'abord, créez un nouveau projet de données:
Fichier [image] Nouveau projet [image] CD(ou DVD) de données
Ouvrez les propriétés du projet:
Fichier [image] Propriétés du projet...
Selectionnez l'onglet ISO, et changez le Format en:
Mode 2 XA (multi-session)

Vous pouvez à présent ajouter des fichiers et des dossiers à votre projet normalement. Reportez-vous à cette section pour plus d'informations sur la façon de travailler en projet.

Continuer un disque multi-session

Pour ajouter des données à un disque multi-session déjà gravé, vous devez d'abord importer les sessions existantes sur le disque. Pour cela, utilisez le menu:
Actions [image] Importer une session...

Une fenêtre vous permettant de sélectionner le périphérique et de voir l'espace alloué et disponible sur le disque va s'ouvrir. Si le bouton OK est grisé, cela signifie que les sessions du disque présent dans le périphérique ne peuvent être importées.

Lorsque vous avez selectionné le périphérique contenant un disque multi-session à importer, cliquez sur le bouton OK, et toutes les données sur le disque vont être ajoutées à votre projet. Les données importées ne peuvent être manipulées ou retirées du disque. Tous les fichiers et dossiers importés apparaissent avec un texte grisé.

Dès que votre travail sur la nouvelle session est terminé et que vous souhaitez ajouter ces données au disque, vous pouvez soit utiliser le menu:
Actions [image] Graver la compilation [image] d'un disque compact...
soit le bouton de la barre d'outils:

Ce qu'il faut savoir de plus sur les disques multi-sessions

En plus des données que vous allez graver, chaque session nécessite 13Mo supplémentaire pour ces informations. Cela implique que la capacité d'un disque va dépendre du nombre de session qui y sont stockées.

Certains lecteurs de CD/DVD peuvent ne pas reconnaitre les sessions qui se trouvent après la première session d'un disque. Si cela se produit, on peut retrouver ces informations en finalisant un disque. Mais on perd dans ce cas la possibilité d'ajouter de nouvelles sessions au disque.


Paramètres projet

Comment faire ?, Travail en projet.
Paramètres projet
Cette section traite des paramètres du projet accessible par le menu:
Fichier [image] Propriétés du projet...

Paramètres généraux

Le seul paramètre général susceptible d'être modifié est l'étiquette du disque. L'étiquette soumise par défaut est basée sur la date et l'heure de création du projet. Notez que le nom de l'étiquette est soumis au même restriction que celui des fichiers du projet (voir la section Paramètres ISO ci-dessous).

Paramètres ISO

Niveau

Cette option définit le niveau de conformité à la norme ISO qui définit la restriction sur le nom des fichier. Il y a trois niveau de restriction gérés par InfraRecorder:

  1. Le niveau 1 utilise des noms de fichier en format 8.3 (huit caractères avec trois caractères pour l'extension), en majuscule, chiffres et caractère souligné(underscore). Le nombre maximum de dossiers dans un chemin est de huit.
  2. Le niveau 2 autorise des noms de fichiers jusqu'à 31 caractères.
  3. Le niveau 3 autorise la fragmentation des fichiers (principalement pour l'écriture par paquets, ou une gravure incrémentale).
  4. Le niveau 4 n'existe pas vraiment, mais lorsqu'il est sélectionné, la norme ISO-9660:1999 (qui est la norme ISO-9660 version 2) est utilisée. Cette norme autorise des noms de fichier jusqu'à 207 caractères, et la profondeur des chemins peut être supérieure à huit.

Format

Cette option spécifie le format utilisé lorsqu'on grave un projet de disque de données. Le Mode 1 is normally used when creating regular non multi-session discs while Mode 2 should be used when creating multi-session discs. Mode 1 allows 2048 bytes of data per sector, Mode 2 allows 2336 bytes of data per sector (A CD-ROM sector is 2352 bytes large).

Autres Options

L'option Utiliser les extensions de nom de fichier Joliet ajoute des enregistrements de dossier Joliet dans le disque en plus du standard de nom de fichier ISO9660. L'extension Joliet est communément utilisée sur les sytèmes Windows, et permet des nom de fichier en format unicode avec une longueur maximum de 64 caractères.

Si cependant, vous souhaitez utiliser des nom de fichiers plus longs, validez l'option Autoriser plus de 64 caractères pour les noms de fichier Joliet. Même si cela n'est pas pleinement compatible avec les spécifications Joliet, cela fonctionne. Le nombre maximum de caractères est alors étendu à 103 caractères.

L'option Omettre les numéros de version des fichiers ISO9660 est explicite.

Validez l'option Utilser les extensions Rock Ridge afin de générer des enrgistrement SUSP et RR utilisant le protocole Rock Ridge qui décrit en détail les fichiers du système de fichiers ISO9660.

Champs

Cette section contient des champs qui permettent de saisir les informations sur les personnes qui ont créées le projet du CD/DVD. Les champs Editeur, Preparateur, Système et Ensemble de Volumes peuvent éditer directement, les autres champs contiennent souvent des nom de fichiers, ce qui limite leur longueur à 36 caractères.

Audio

Cette section permet de créer des information CD-Text. Le CD-Text est un format qui peut être supporté par certain lecteur CD audio, et qui permet d'afficher le nom de l'artiste et des chansons lorsque le disque est en lecture. Ces option ne sont valable que dans les projets en mode audio ou en mode mixte.

Boot

Cette section n'est disponible que dans les projets de données, et vous permet de spécifier jusqu'à 63 images de boot qui pourront être utilisées pour créer un CD/DVD bootable "El Torito". Pour ajouter une image de boot au projet, cliquez sur le bouton Ajouter une nouvelle image de boot au projet :
Référez-vous à la section Ajouter une image de boot pour plus d'information.


Ajouter une image de boot

Comment faire ?, Travail en projet.
Ajouter une image de boot

Plusieurs options peuvent être définies lorsque vous ajoutez une image de boot à votre projet.

Chemin local

Dans ce champs, vous devez spécifié le chemin local de l'image de boot sélectionnée. Le chemin est relatif à la racine du disque. Par exemple: /boot/ va créer un répertoire appelé boot à la racine du disque qui contiendra le fichier sélectionné.

Type d'émulation

Cette option vous permet de choisir un type d'émulation pour un disque bootable de type "El Torino". Si l'émulation choisie est de type disquette, la taille du fichier image de boot doit être exactement la même que celle d'une disquette de 1200, 1440 ou 2880 Ko. Si l'émulation est de type disque dur, l'image de boot doit impérativement commencer avec un MBR (Section de boot principale du disque) qui contient une seule partition. Si aucune émulation n'est définie, le système chargera et executera l'image de boot sans aucune émulation disque.

Options avancées

L'option Faire une image non bootable vous permet d'empêcher de booter sur le CD/DVD. Le système emulera un disque à partir l'image de boot sur le CD/DVD, mais bootera sur son disque de boot standard.

Enabling the Write boot-info-table to the image option will cause the boot image to be patched at offset 8 with a 54-byte table containing information about the disc layout. If this option is enabled the local boot image that you have specified will be patched, so make sure that you have a backup of this file if it can't be easily regenerated.

Le champ Segment boot load vous permet de définir une adresse de démarrage (en hexadécimale) dans le cas où aucune émulation pour les disques bootable "El Torito" discs.

Le champ Taille du boot load vous permet de définir le nombre de secteurs virtuels (512 octets) à charger dans le cas où aucune émulation n'est définie. Il est recommandé de charger la totalité du fichier de boot. Certains BIOS sur les cartes mère peuvent avoir des problèmes si la taille du boot load n'est pas un multiple de 4.


Graver une image disque

Comment faire ?
Graver une image disque
Pour graver ou enregistrer une image disque, vous pouvez soit passer par le menu:
Actions [image] Graver l'image...
ou par le bouton de la barre d'outils:

Il vous sera demandé de sélectionner l'image disque, sur votre disque dur, que vous souhaitez gravez.

Options

Une description détaillée des options disponible apparaît dans cette section.


Options de gravure

Comment faire ?
Options de gravure

Cette section concerne les options de gravure qui peuvent être appelées de plusieurs endroit dans InfraRecorder. Par exemple, lorsque vous souhaitez votre propre compilation, une image disque ou faire une copie d'un disque.

Bien que ces options soient accessibles dans différents contextes, l'interface se présente toujours de la même manière :

Paramètres généraux

A la volée

Lorsqu'on grave à la volée, tout le système de fichiers sera généré au moment de la gravure, ce qui peut augmenter le risque d'erreur d'écriture. Si cette option est invalidée, une image temporaire du disque sera générée sur le disque dur, puis enregistrée sur le disque à graver. Par défaut, cette option est invalide. Elle ne devrait être validé que si vous manquez d'espace sur votre disque dur.

Vérifier le disque après écriture

En validant cette option, InfraRecorder effectuera une comparaison CRC entre les fichiers sources sur votre disque dur, et les fichiers cibles qui se trouvent sur le disque qui vient d'être gravé afin de s'assurer qu'aucune erreur d'écriture ne s'est produite sur le disque.

Vitesse d'écriture

Sélectionne la vitesse de gravure sur le disque. En sélectionnant l'option Maximum, la vitesse la plus haute supportée par le disque ou la graveur sera utilisée.

Méthode d'écriture

Cette option sélectionne la méthode d'écriture utilisée lors de la gravure du disque. Seules les méthodes supportées par votre graveur seront listées.

Session-At-Once (SAO) appelé aussi Disc-At-Once (DAO) , cette méthode écrit toutes les données (lead-in et lead-out inclus) en une seule passe. Sans autoriser aucune interruption dans le flux de données. Aucune session ou données ne peuvent être ajoutées ultérieurement sur le disque. Notez que les DVD doivent obligatoirement être gravés suivant cette méthode.

Track-At-Once (TAO) écrit chaque piste indépendemment ce qui requiert des blocs de lien entre deux pistes. Les anciens graveurs créent souvent une pause de deux secondes entre les piste (appelé pregap) alors que les graveurs les plus récents autorisent un ajustement de la durée du pregap (voir l'option décrite plus bas).

TAO pregap zéro utilise la méthode Track-At-Once décrite plus haut en essayant de définir une durée de pregap à zéro en réduisant au maximum le nombre de blocs de lien entre deux pistes.

Ecriture directe (raw96r) écrit les données brutes en utilisant des secteurs de 2352 octets plus 96 octets du sous canal P-W créant ainsi des secteur de 2448 octets. Il s'agit de la méthode la plus courante d'écriture en direct car le contrôle de l'écriture sur le CD est bien plus fiable.

Ecriture directe (raw16) écrit les données brutes en utilisant des secteurs de 2352 octets plus 16 octets du sous canal P-Q créant ainsi des secteur de 2368 octets. Cette méthode sera utilisé si un graveur ne supporte pas l'écriture directe (raw96r). Cette méthode d'écriture ne prendra pas en charge les CD-Text.

Ecriture directe (raw96p) écrit les données brutes en utilisant des secteurs de 2352 octets plus 96 octets du sous canal P-W créant ainsi des secteur de 2448 octets. Cette méthode est à éviter dans la mesure où peu de graveurs la supportent, et beaucoup de ces graveurs ont des bogues dans leur firmware. N'utilisez pas cette méthode sir votre graveur supporte l'écriture directe raw96r ou raw16.

Important: Notez que l'écriture directe a un besoin de puissance processeur bien plus important que pour les autres méthodes. Si votre processeur est très lent, vous pouvez rencontrer des problèmes perte de mémoire tampon lors de la gravure.

Autres options

La validation de l'option Simulation va faire en sorte que Infrarecorder va effectuer les opérations demandés mais avec le laser du graveur éteint. Cette option est recommendé si vous souhaitez vous assurer que la gravure du projet se déroulera correctement ou pas.

Protection "Buffer underrun" est une focntionnalité présente sur les graveurs les plus récents qui autorise la poursuite de la gravure même si la mémoire tampon du graveur se vide complètement. Cette fonctionnalité peut avoir des noms différents suivant les marques d'équipement avec par exemple: Yamaha Lossless-Link, Sanyo BURN-Proof, Ricoh Just-Link, etc. Le nom le plus communément rencontré pour cette fonctionnalité est BURN-Proof.

Si l'option Complète les données des pistes (Pad data tracks) est validé, 15 secteurs nulls seront écrit après chaque piste de données ou audio. Cette option sera utilisé dans le cas ou votre lecteur as des difficultés à lire les derniers secteurs d'une piste. Cette option est aussi utile dans le cas ou vous souhaitez utiliser le disque avec un système de fichier Linux ISO-9660 contenant un bogue dit "read ahead".

Si vous invalidez l'option Finaliser le disque après écriture, la dernière session (si vous utilisez le mode SAO) ou la dernière piste (dans le cas d'un mode TAO) ne sera pas fermée. Ceci peut s'avérer utile si vous souhaitez graver un CD en plusieurs étapes.

Important: La création d'un disque non finalisé ne correspond pas à la création d'un disque multi-session.

Paramètres avancés

L'option Autoriser l'overburning permet de graver au dela de la taille officielle du média. Le fait est que la plupart des médias vierges peuvent supporter plus que leur taille officielle, car la zone allouée au "lead-out" est de 90 secondes (soit 6750 secteurs), et qu'un disque fonctionne avec seulement 150 secteurs affectés au "lead-out". Les médias peuvent ainsi être surchargés d'au moins 88 secondes (6600 secteurs). Le majorité des graveur ne supporte l'overburning qu'en mode d'écriture SAO ou raw. Certains graveur ne vous autorisent pas non plus de surcharger le disque comme vous le souhaiteriez, et peuvent limiter la taille du disque. Ce problème peut cependant être contourné en gravant en mode raw, car dans ce cas, le graveur n'a aucune chance de connaître la taille du disque avant le lancement de la gravure.

Lorsque l'option Echanger l'ordre des octets audio est validée, cela suppose que l'ordre des octets est inversé (little endian). Certains modèle de graveurs de Yamaha ou Sony par exemple ainsi que les graveurs utilisant les nouvelles interfaces SCSI-3/MMC on besoin d'un mode d'adressage des données audio de type little-endian, alors que les autres ont besoin que les données audio soit de type big-endian (réseau) normalement utiliser par le protocole SCSI. L'ordre d'adressage des données audio sera automatiquement détecté. La seule condition qui nécessite de valider cette option sera dans le cas d'un flux de données Intel (little-endian).

Ignorer la taille du média peut être validée si vous souhaitez passez outre la taille connue du média. Cette option doit être utilisée avec précaution. Cette option implique un overburning.

L'option Positionner le drapeau "SCSI IMMED" va imposer un retour immédiat d'une commande SCSI pendant que l'action se déroule en arrière plan. Le bus SCSI sera ainsi disponible pour les autres périphériques qui s'y trouvent, ce qui évitera au système de se figer si le graveur ne répond pas immédiatement. Ceci peut être utile sur des vieux systèmes utilisant un disque dur ATAPI et un graveur sur le même bus, ou sur un système SCSI qui ne supporte pas le mode connecté/déconnecté. Ces systèmes se figerons lors de l'effacement ou la cloture d'un disque, ou lors du remplissage de la session avec la quantité mini de données. Notez que tous les graveurs supportent le drapeau IMMED.

Yamaha Audio Master Q. R. est une fonctionnalité qui permet de créer des disques audio de haute qualité avec moins de problèmes de lecture dans les platines CD de salon. Sa mise en oeuvre est une variante du mode d'écriture SAO, c'est pourquoi vous n'aurez accès à cette option seulement si vous avez sélectionné le mode d'écriture session-at-once. Cette option ne fonctionne pas à toutes les vitesses de gravure, et n'autorise la même quantité de donnée qu'en mode standard à cause du fait que le sillon de gravure sera élargi. Si cette option est validé, un CD de 74 minutes verra sa capacité réduite à 63 minutes et un CD de 80 minutes descendra à 68 minutes. Cette fonctionnalité fonctionne également avec les disques de données.

L'option Forcespeed mode force le graveur à utiliser la vitesse sélectionnée sans se soucier de la qualité du média. Normallement, le graveur est sensé connaître la vitesse de gravure maxi autorisée en fonction du média, et peut réduire la vitesse pour assurer la meilleure qualité de gravure. Utilisez cette option avec précaution et en connaissance de cause, car habituellement, le graveur sait très bien quel média peut être gravé à pleine vitesse.

L'option Plextor VariRec write mode autorise à l'utilisateur un léger ajustement de la puissance du laser. Si cette option est configuré correctement, cela peut réduire le jitter, ce qui donnera une meilleure qualité sonore, et diminuera les risques d'incompatibilité avec votre lecteur de salon. VariRec ne fonctionnne que si la vtesse de gravure est définie x4.


Options de lecture

Comment faire ?
Options de lecture

Cette section couvre les options de lecture qui peuvent apparaitre à plusieurs moment au sein d'InfraRecorder. Par exemple, lorsque vous souhaitez un disque vers une image ou vers un autre disque.

Bien que ces options puissent apparaitre dans différent contextes, elles se présentent toujours de la même manière :

Paramètres de lecture

Ignorer les erreurs de lecture

Valider cette option fera en sorte de ne pas abandonner le process en cours si une erreur de lecture de haut niveau est détectée dans le flux de données. Le lecteur/graveur sera également placé dans un mode ou il ignore toute erreur de lecture dans les secteur de données qui résulte d'un ECC/EDC incorrect.

Lire toutes les données sub-channel et toute la TOC

Lorsque cette option est validée, le disque sera lu avec toute les données sub-channel et toute la table d'allocation (TOC). Toutes les données de la TOC seront placées dans un fichier avec le même nom que le fichier image, mais avec le suffixe .toc.

Vitesse de lecture

Sélectionnez la vitesse de lecture du disque. Sélectionner l'option Maximum va automatiquement sélectionner la vitesse de lecture la plus haute supportée par le lecteur.

Définir une vitesse de lecture plus basse peut augmenter la lisibilité du disque.


Copie de disques audios

Comment faire ?
Copie de disques audios
Copier un disque audio nécessite plus d'étapes que pour une copie de disque de données. Vous devz d'abord sauver les pistes audios sur votre disque dur. Pour cela, ouvrez la boite de dialogue des pistes par le menu :
Actions [image] Gérer les pistes...
La fenêtre devrait être similaire à l'aperçu ci-dessous lorsque vous aurez sélectionné votre lecteur source et inséré un disque audio :
Sélectionnez les piste que vous souhaitez sauvegarder (copier) en cliquant sur une piste de départ, puis une piste de fin en maintenant la touche MAJ enfoncé. Lorsque vos piste sont sélectionnées, cliquez sur le bouton Enregistrer les pistes sélectionnées sur le disque dur :

Il vous sera demandé de spcifier le répertoire de destination pour l'enregistrement des pistes. Sélectionnez le répertoire de votre choix. Lorsque cela est fait, toutes les pistes que vous avez sélectionnées seront sauvée à l'emplacement spécifié (sauf en cas d'erreur de lecture majeur du CD audio).

La prochaine étape consiste à créer un projet audio, et d'y ajouter les pistes que vous venez de sauver sur votre disque dur. Pour plus d'informations, consultez cette section.


Copie de disques de données

Comment faire ?
Copie de disques de données

Veuillez noter que cette page contient des informations sur la marche à suivre pour copier une CD/DVD de données. Si vous souhaitez copier un CD audio (ce qui est une procédure complètement différente) référez-vous à cette section.

Si vous souhaitez copier un disque de données, vous avez deux options qui sont : Voulez-vous copier le disque vers un autre disque (par exemple d'un lecteur CD vers un graveur CD) ou vers une image disque sur votre disque dur.

Copier vers un autre disque

Pour copier un disque directement, utilisez le menu :
Actions [image] Copier le disque [image] d'un disque compact...
ou le bouton de la barre d'outil :

Source

Sélectionnez le lecteur contenant le CD/DVD que vous souhaitez copier.

Destination

Sélectionnez le graveur qui contient le CD/DVD vierge sur lequel sera gravé la copie. Si la destination est la même que la source, vous ne pourrez pas faire de copie à la volée.

A la volée

L'écriture à la volée signifie que les données seront lues du lecteur source et écrites directement sur le graveur de destination sans passer par un fichier tampon sur votre disque dur (seule une petite quantité de mémoire tampon sera allouée). Si votre lecteur source échoue à la lecture de certains secteurs de votre disque source, il pourrait ne pas être capable d'alimenter assez rapidement le graveur de detination, ce qui provoquerait des erreurs d'écriture sur le disque de destination. Cependant, la plupart des graveur récent offre des protections de chute du tampon à 0 qui devrait protèger le disque de destination si cela devait se produire.

Si l'option A la volée est invalidée, une image temporaire du disque sera créée sur votre disque dur. A l'issue de cette opération, l'image disque temporaire sera alors gravée sur le disque de destination. Cette opération nécessitera plus d'espace disponible sur votre disque dur, mais sera plus sécurisante pour l'écriture des données.

Cloner le disque

Lorsque cette option est validée, tous les sous-canaux de données ainsi que la table d'allocation complète (TOC) du disque source seront également copiés sur le disque cible. Cette option doit être valide si vous copiez un disque en mode mixte, sans quoi, seule la piste de données sera copié. Il est recommandé de copier la destination en mode raw96r. Si cette méthode n'est pas supportée par votre graveur, essayez de spécifier une méthode d'écriture raw16.

Options de lecture

Les options de lecture sont décrites dans cette section.

Autres options

Les autres options sont décrites dans cette section.

Copier vers une image disque

Pour copier un disque dans un fichier image sur votre disque dur, utilisez le menu :
Actions [image] Copier le disque [image] sur une image disque...

Source

Sélectionnez le lecteur source qui contient le CD/DVD que vous souhaitez copier.

Fichier image

Spécifiez l'emplacement et le nom du fichier image. Notez que la taille du fichier qui sera écrit sur le disque dur sera de la taille du CD/DVD à copier. Vous devez donc vous assurer qu'il y a assez de place sur votre disque dur.

Options de lecture

Les options de lecture sont décrites dans cette section.


Les informations du disque

Comment faire ?
Les informations du disque
Pour voir les informations détaillées d'un disque inséré dans le lecteur/graveur de votre PC, utilisez le menu :
Actions [image] Information sur le disque [image] <sélectionnez le périphérique contenant le disque qui vous intéresse>

Champs d'information

Le champ Type de disque affiche le type de disque inséré comme par exemple: CD-R, DVD+R DL.

Le champ Type de média n'est valide qu'avec un DVD et affiche son "book type", c'est à dire, le format physique du DVD (DVD-ROM, DVD-RAM, etc...)

Le champ Région affiche pour quelle région est encodé le DVD. Les numéros de régions sont les suivants :

  1. Etats unis, Canada.
  2. Europe, ainsi que France, Grèce, Turquie, Egypte, Arabie, Japon et Afrique du Sud.
  3. Corée, Thaïlande, Vietnam, Bornéo et Indonésie.
  4. Australie et Nouvelle-Zélande, Méxique, les Caraibes et l'Amerique du Sud.
  5. Inde, Afrique, Russie et pays d'ex URSS.
  6. République Populaire de Chine.
  7. Inutilisé.
  8. Compagnies aériennes et bateaux de croisières.
  9. Etendue (cela correspond souvent à un disque dézonné).

Le champ Couche affiche le nombre de couche sur un DVD.

Le champ Pistes affiche le nombre de piste présentes sur le disque.

Le champ Sessions affiche le nombre de sessions présentes sur le disque.

Le champ Statut affiche des informations sur le statut du disque et de ces sessions ainsi que l'information si le disque est effaçable ou pas.

Le champ Espace utilisé affiche la taille de l'espace utilisé sur le disque.

Le champ Espace libre affiche la taille de l'espace disponible sur le disque.


Effacer des disques ré-inscriptibles

Comment faire ?
Effacer des disques ré-inscriptibles
Pour effacer un disque réinscriptible, vous pouvez soit utiliser le menu :
Actions [image] Effacer/Formatter un disque...
soit par le bouton de la barre d'outils :

Graveur

Sélectionnez le graveur dans lequel se trouve le disque à effacer.

Méthode d'effacement

Sélectionnez une des quatre méthode d'effacement à utiliser. La méthode Effacer tout le disque effacera toutes les données physiquement présentes sur le disque. Cette méthode peut être très longue. En utilisant la méthode Effacer le disque en mode rapide, seule la table d'allocation (TOC), PMA et le pregap seront effacés. Les données effective ne sont pas effacées du disque (mais elle ne seront plus accessible). Au lieu de cela, les données seront écrasées par les données que vous écrirez sur le disque à la prochaine gravure. Cette méthode est beaucoup plus rapide, car elle est effectuée le plus souvent en une dizaine de secondes. La méthode Annule la fermeture de la dernière session annule la fermeture de la dernière session (sur un disque multi-session finalisé) permettant ainsi de rajouter des sessions sur le disque. La dernière méthode Effacer la dernière session va simplement effacer la dernière session enregistré sur le disque. Le temps d'effacement de la dernière session dépendra de la taille de celle-ci.

Autres options

Si la table d'allocation (TOC) a été endommagée sur le disque, InfraRecorder n'effacera pas le disque à moins que l'option Ignorer le TOC illégal soit activée.

Activer l'option Simulation demandera à InfraRecorder d'effectuer l'effacement avec le laser éteint. Cette opération est recommandé si vous voulez savoir si l'opération se déroulera correctement ou pas.


Finaliser un disque

Comment faire ?
Finaliser un disque
Un disque finalisé est un disque qu'on peut considéré terminé. Normallement, un disque est automatiquement finalisé après l'écriture des données. Cet outil est utile si les données ont été écrites mais n'ont, pour quelques raisons que ce soit, pas été finalisées. Pour finaliser un disque, utilisez le menu :
Actions [image] Finaliser le disque...

Graveur

Sélectionnez le graveur dans lequel se trouve le disque à finaliser.

Autres options

Activer l'option Simulation demandera à InfraRecorder d'effectuer la finalisation avec le laser éteint. Cette opération est recommandé si vous voulez savoir si l'opération se déroulera correctement ou pas.


Gérer les pistes

Comment faire ?
Gérer les pistes
L'outil Gérer les pistes affiche les informations de la table d'allocation (TOC) du disque inséré dans le lecteur/graveur. Il offre également la possibilité de vérifier et sauver les pistes sélectionnées. Pour ouvrir le gestionnaire de pistes, utilisez le menu :
Actions [image] Gérer les pistes...

Sélectionnez les piste désirées en cliquant dessus avec la souris en maintenant la touche MAJ ou CTRL appuyé. Vous pouvez également utiliser les flèches du clavier et la touche MAJ pour sélectionner les pistes dans la liste.

Lorsque vous sauvgardez une piste sur votre disque dur, vous aurez à sélectionner un dossier de sauvegarde. Les pistes seront alors automatiquement sauvées et nommées suivant leur numéro et type (Track 1.wav, Track 2.iso). Pour sauver les pistes sélectionnées sur votre disque dur, cliquez sur le bouton Enregistrer les pistes sélectionnées sur le disque dur :
Pour rechercher des erreurs sur les pistes sélectionnées, utilisez le bouton Rechercher des erreurs sur les pistes sélectionnées :

Ci-dessous le résultat après la vérification d'une piste de données :.

Vous pouvez également effacer les pistes sélectionnées si votre disque est réinscriptible ne cliquant sur le bouton Effacer les pistes sélectionnées du disque :


Configurer les périphériques

Comment faire ?
Configurer les périphériques
Si vous avez fait des modification sur votre matériel, vous aurez probalbement à en informer InfraRecorder. Pour afficher la configuration des périphériques d'InfraRecorder, utilisez le menu :
Options [image] Matériel...

Vous verrez alors la liste des périphériques qui ont été détectés par InfraRecorder. Si vous voulez mettre à jour la liste des périphérique, cliquez sur le bouton Nouvelle recherche. Cela demandera à InfraRecorder d'éffectuer une nouvelle recherche complète sur les périphériques supportés sur votre machine.


Configuration

Comment faire ?
Configuration
Pour accéder aux options de InfraRecorder, utilisez le menu:
Options [image] Configuration...

Paramètres généraux

L'option Vérifier si "autorun" est actif à chaque démarrage va interdire l'autorun lorsqu'un CD est inséré dans le lecteur/graveur, et que InfraRecorder est lancé. Il est recommandé que l'autorun soit inactif, sans quoi, Windows peut lancer des applications qui sont sur le CD alors qu'une gravure est lancé. Ceci peut endommager le CD.

L'option Afficher l'écran de bienvenue au démarrage affiche l'écran qui vous permet de sélectionner le projet que vous souhaitez créer. Si cette option est invalide, le projet Cd de données sera sélectionné par défaut.

Les options Associer InfraRecorder aux fichiers .irp, et Associer InfraRecorder avec les images disque si elles sont validées, lancerons automatiquement InfraRecorder avec ces fichiers lorsque vous double-cliquerez sur ce type de fichiers dans l'explorateur Windows.

Si vous voulez que InfraRecorder se rappelle du dernier répertoire utilisé dans la vue explorateur, vous pouvez cocher Se souvenir du dernier dossier actif. Sinon, vous pouvez spécifier un dossier par défaut utilisé à chaque démarrage de InfraRecorder.

L'option Dossier Temporaire vous permet de spécifier l'emplacement du dossier où seront stocker tout les fichiers temporaires de l'application sur votre disque dur comme les images disque par exemple. Si votre disque dur ou votre partition sur laquelle vous stockez ces fichiers temporaires est presque pleine, cela peut être une bonne idée d'utiliser un autre disque dur pour ce fichier temporaire.

Paramètres avancés

Si vous souhaitez activer la fonctionnalité de journalisation (log), cochez l'option Activer le log. Ceci peut s'avérer utile si vous souhaitez pister un bogue ou une erreur dans InfraRecorder. Il n'est cependant pas souhaitable de laisser le log actif si vous ne souhaitez pas pister d'événement spécial, car le log nécessite plus de mémoire et de temps CPU.

L'option Activer l'effet de fumée valide ou invalide l'affichage d'une colonne de fumée durant la gravure. L'effet de fumée nécessite l'activation de l'effet Aero dans Windows Vista soit activé. Si Aero n'est pas activé, cette option n'aura aucun effet.

L'option Taille du tampon FIFO permet de chnager la quantité de mémoire RAM utilisée pour le tampon en plus de de la taille du buffer physique du graveur. Augmenter la taille du tampon peu permettre d'avoir une gravure plus stable. En règle générale, la taille du FIFO ne doit pas être inférieure à la taille physique du tampon du graveur, et ne doit pas être supérieure à la moitié de la RAM installée sur votre PC. Si vous faites souvent des gravures à la volée, vous devez paramètrer une taille importante de tampon FIFO (par exemple 128MiB) pour éviter toute rupture (underrun) des données lors de la gravure.

Paramètre de langue

Une liste des langues disponible est affichée dans la boîte de sélection. Pour changer la langue, sélectionnez simplement la langue que vous souhaitez, cliquez sur le bouton OK, et redémarrez InfraRecorder. Si la langue que vous souhaitez n'est pas disponible, vérifiez sur le site InfraRecorder si votre langue existe.

Extension

L'extension shell (lorsque elle est activée) ajoute une commande supplémentaire au menu contextuel de l'explorateur Windows :

Cela rajoute l'option de graver une image dique, ou un projet InfraRecorder juste en faisant un clic droit sur le fichier au sein de l'explorateur.

L'extension shell peut être personnalisée pour ajouter les commandes dans un sous-menu. Pour cela, validez l'option Afficher les menus contextuels dans des sous-menus.

On peut aussi personnaliser l'extension shell pour qu'elle n'affiche pas les icônes dans les commandes du menu en invalidant l'option Afficher les icônes dans les menus.

Associer l'Extension Shell

L'extension Shell n'est pas associé automatiquement avec les images disque, et les projet InfraRecorder. Lorsqu'on valide l'option Activer l'extension InfraRecorder, InfraRecorder Informe l'explorateur Windows que d'autres applications peuvent faire appel à ces fonctionnalités étendues.

Pour permettre à l'exlorateur Windows d'utiliser les fonctionnalités étendues fournies par l'extension shell d'InfraRecorder, l'extension shell doit être associée avec des types de fichier susceptibles d'utiliser ces fonctionnalités.

Il existe un jeu prédéfini d'extensions de fichiers disponible dans la liste. Pour associer l'extension shell d'IInfraRecorder à un type de fichier, cochez le type de fichier disponible dans la liste. Vous pouvez rajouter n'importe quel autre type de fichier à la liste en cliquant sur le bouton Ajouter une nouvelle extension de fichier à la liste :