Úvod

Infra Recorder
Úvod

Vítejte

Děkujeme, že jste si nainstalovali Infra Recorder! Infra Recorder je bezplatné řešení pro vypalování CD/DVD pod Microsoft Windows.

Rychlá navigace

Přehled funkcí
Licenční ujednání
Systémové požadavky
Quick Start
Copyright
Poděkování
Co je nového
Instalace


Přehled funkcí

Infra Recorder
Přehled funkcí

Na této stránce naleznete seznam nejpodstatnějších funkcí Infra Recorder.

Hlavní funkce

  • Tvorba datových, hudebních a mixed-mode projektů a jejich záznam na kompaktní disky nebo do obrazů.
  • Tvorba a vypalování obrazů disků.
  • Přímé kopírování disků on the fly nebo za pomoci dočasného obrazu disku.
  • Mazání přepisovatelných disků s možností výběru ze čtyř režimů mazání.
  • Import sekcí multisession disků a přidávání dalších sekcí na tyto disky.
  • Uzavírání disků (zápis lead-out pro znemožnění přidávání dalších dat).
  • Vyhledávání mechanik připojených k SCSI/IDE řadičům a detekce funkcí, které tyto mechaniky podporují.
  • Zobrazení detailních informací o vloženém disku.
  • Čtení a ukládání zvukových a datových stop do souborů (wav. a .iso)
  • Vyhledávání chyb.

Prostředí

  • Moderní přizpůsobitelné prostředí podobající se Průzkumníkovi Windows.
  • Podpora drag and drop pro přetahování souborů do projektu z interního průzkumníka i Průzkumníka Windows.
  • Rozdílné rozvržení rozhraní podle typu aktivního projektu usnadňující práci s programem.
  • Samostatná express aplikace navržená k rychlému a snadnému navedení uživatele k těm správným nástrojům.
  • Kompletně přeložitelné rozhraní hlavní aplikace, express aplikace a rozšíření průzkumníka.

Integrace do Průzkumníka

Integrace do Průzkumníka přidává nové položky kontextové nabídky.

  • Zápis uložených projektů a obrazů disků.
  • Otevírání a editace projektů.
  • Přizpůsobitelné, může být zobrazeno jako podnabídka a s nebo bez ikon.
  • Rozšíření může být zaregistrováno pro kteroukoliv příponu souboru.


License Agreement

InfraRecorder
License Agreement

GNU GENERAL PUBLIC LICENSE

Version 3, 29 June 2007

Copyright © 2007 Free Software Foundation, Inc. <http://fsf.org/>

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

Preamble

The GNU General Public License is a free, copyleft license for software and other kinds of works.

The licenses for most software and other practical works are designed to take away your freedom to share and change the works. By contrast, the GNU General Public License is intended to guarantee your freedom to share and change all versions of a program--to make sure it remains free software for all its users. We, the Free Software Foundation, use the GNU General Public License for most of our software; it applies also to any other work released this way by its authors. You can apply it to your programs, too.

When we speak of free software, we are referring to freedom, not price. Our General Public Licenses are designed to make sure that you have the freedom to distribute copies of free software (and charge for them if you wish), that you receive source code or can get it if you want it, that you can change the software or use pieces of it in new free programs, and that you know you can do these things.

To protect your rights, we need to prevent others from denying you these rights or asking you to surrender the rights. Therefore, you have certain responsibilities if you distribute copies of the software, or if you modify it: responsibilities to respect the freedom of others.

For example, if you distribute copies of such a program, whether gratis or for a fee, you must pass on to the recipients the same freedoms that you received. You must make sure that they, too, receive or can get the source code. And you must show them these terms so they know their rights.

Developers that use the GNU GPL protect your rights with two steps: (1) assert copyright on the software, and (2) offer you this License giving you legal permission to copy, distribute and/or modify it.

For the developers' and authors' protection, the GPL clearly explains that there is no warranty for this free software. For both users' and authors' sake, the GPL requires that modified versions be marked as changed, so that their problems will not be attributed erroneously to authors of previous versions.

Some devices are designed to deny users access to install or run modified versions of the software inside them, although the manufacturer can do so. This is fundamentally incompatible with the aim of protecting users' freedom to change the software. The systematic pattern of such abuse occurs in the area of products for individuals to use, which is precisely where it is most unacceptable. Therefore, we have designed this version of the GPL to prohibit the practice for those products. If such problems arise substantially in other domains, we stand ready to extend this provision to those domains in future versions of the GPL, as needed to protect the freedom of users.

Finally, every program is threatened constantly by software patents. States should not allow patents to restrict development and use of software on general-purpose computers, but in those that do, we wish to avoid the special danger that patents applied to a free program could make it effectively proprietary. To prevent this, the GPL assures that patents cannot be used to render the program non-free.

The precise terms and conditions for copying, distribution and modification follow.

TERMS AND CONDITIONS

0. Definitions.

“This License” refers to version 3 of the GNU General Public License.

“Copyright” also means copyright-like laws that apply to other kinds of works, such as semiconductor masks.

“The Program” refers to any copyrightable work licensed under this License. Each licensee is addressed as “you”. “Licensees” and “recipients” may be individuals or organizations.

To “modify” a work means to copy from or adapt all or part of the work in a fashion requiring copyright permission, other than the making of an exact copy. The resulting work is called a “modified version” of the earlier work or a work “based on” the earlier work.

A “covered work” means either the unmodified Program or a work based on the Program.

To “propagate” a work means to do anything with it that, without permission, would make you directly or secondarily liable for infringement under applicable copyright law, except executing it on a computer or modifying a private copy. Propagation includes copying, distribution (with or without modification), making available to the public, and in some countries other activities as well.

To “convey” a work means any kind of propagation that enables other parties to make or receive copies. Mere interaction with a user through a computer network, with no transfer of a copy, is not conveying.

An interactive user interface displays “Appropriate Legal Notices” to the extent that it includes a convenient and prominently visible feature that (1) displays an appropriate copyright notice, and (2) tells the user that there is no warranty for the work (except to the extent that warranties are provided), that licensees may convey the work under this License, and how to view a copy of this License. If the interface presents a list of user commands or options, such as a menu, a prominent item in the list meets this criterion.

1. Source Code.

The “source code” for a work means the preferred form of the work for making modifications to it. “Object code” means any non-source form of a work.

A “Standard Interface” means an interface that either is an official standard defined by a recognized standards body, or, in the case of interfaces specified for a particular programming language, one that is widely used among developers working in that language.

The “System Libraries” of an executable work include anything, other than the work as a whole, that (a) is included in the normal form of packaging a Major Component, but which is not part of that Major Component, and (b) serves only to enable use of the work with that Major Component, or to implement a Standard Interface for which an implementation is available to the public in source code form. A “Major Component”, in this context, means a major essential component (kernel, window system, and so on) of the specific operating system (if any) on which the executable work runs, or a compiler used to produce the work, or an object code interpreter used to run it.

The “Corresponding Source” for a work in object code form means all the source code needed to generate, install, and (for an executable work) run the object code and to modify the work, including scripts to control those activities. However, it does not include the work's System Libraries, or general-purpose tools or generally available free programs which are used unmodified in performing those activities but which are not part of the work. For example, Corresponding Source includes interface definition files associated with source files for the work, and the source code for shared libraries and dynamically linked subprograms that the work is specifically designed to require, such as by intimate data communication or control flow between those subprograms and other parts of the work.

The Corresponding Source need not include anything that users can regenerate automatically from other parts of the Corresponding Source.

The Corresponding Source for a work in source code form is that same work.

2. Basic Permissions.

All rights granted under this License are granted for the term of copyright on the Program, and are irrevocable provided the stated conditions are met. This License explicitly affirms your unlimited permission to run the unmodified Program. The output from running a covered work is covered by this License only if the output, given its content, constitutes a covered work. This License acknowledges your rights of fair use or other equivalent, as provided by copyright law.

You may make, run and propagate covered works that you do not convey, without conditions so long as your license otherwise remains in force. You may convey covered works to others for the sole purpose of having them make modifications exclusively for you, or provide you with facilities for running those works, provided that you comply with the terms of this License in conveying all material for which you do not control copyright. Those thus making or running the covered works for you must do so exclusively on your behalf, under your direction and control, on terms that prohibit them from making any copies of your copyrighted material outside their relationship with you.

Conveying under any other circumstances is permitted solely under the conditions stated below. Sublicensing is not allowed; section 10 makes it unnecessary.

3. Protecting Users' Legal Rights From Anti-Circumvention Law.

No covered work shall be deemed part of an effective technological measure under any applicable law fulfilling obligations under article 11 of the WIPO copyright treaty adopted on 20 December 1996, or similar laws prohibiting or restricting circumvention of such measures.

When you convey a covered work, you waive any legal power to forbid circumvention of technological measures to the extent such circumvention is effected by exercising rights under this License with respect to the covered work, and you disclaim any intention to limit operation or modification of the work as a means of enforcing, against the work's users, your or third parties' legal rights to forbid circumvention of technological measures.

4. Conveying Verbatim Copies.

You may convey verbatim copies of the Program's source code as you receive it, in any medium, provided that you conspicuously and appropriately publish on each copy an appropriate copyright notice; keep intact all notices stating that this License and any non-permissive terms added in accord with section 7 apply to the code; keep intact all notices of the absence of any warranty; and give all recipients a copy of this License along with the Program.

You may charge any price or no price for each copy that you convey, and you may offer support or warranty protection for a fee.

5. Conveying Modified Source Versions.

You may convey a work based on the Program, or the modifications to produce it from the Program, in the form of source code under the terms of section 4, provided that you also meet all of these conditions:

  • a) The work must carry prominent notices stating that you modified it, and giving a relevant date.
  • b) The work must carry prominent notices stating that it is released under this License and any conditions added under section 7. This requirement modifies the requirement in section 4 to “keep intact all notices”.
  • c) You must license the entire work, as a whole, under this License to anyone who comes into possession of a copy. This License will therefore apply, along with any applicable section 7 additional terms, to the whole of the work, and all its parts, regardless of how they are packaged. This License gives no permission to license the work in any other way, but it does not invalidate such permission if you have separately received it.
  • d) If the work has interactive user interfaces, each must display Appropriate Legal Notices; however, if the Program has interactive interfaces that do not display Appropriate Legal Notices, your work need not make them do so.

A compilation of a covered work with other separate and independent works, which are not by their nature extensions of the covered work, and which are not combined with it such as to form a larger program, in or on a volume of a storage or distribution medium, is called an “aggregate” if the compilation and its resulting copyright are not used to limit the access or legal rights of the compilation's users beyond what the individual works permit. Inclusion of a covered work in an aggregate does not cause this License to apply to the other parts of the aggregate.

6. Conveying Non-Source Forms.

You may convey a covered work in object code form under the terms of sections 4 and 5, provided that you also convey the machine-readable Corresponding Source under the terms of this License, in one of these ways:

  • a) Convey the object code in, or embodied in, a physical product (including a physical distribution medium), accompanied by the Corresponding Source fixed on a durable physical medium customarily used for software interchange.
  • b) Convey the object code in, or embodied in, a physical product (including a physical distribution medium), accompanied by a written offer, valid for at least three years and valid for as long as you offer spare parts or customer support for that product model, to give anyone who possesses the object code either (1) a copy of the Corresponding Source for all the software in the product that is covered by this License, on a durable physical medium customarily used for software interchange, for a price no more than your reasonable cost of physically performing this conveying of source, or (2) access to copy the Corresponding Source from a network server at no charge.
  • c) Convey individual copies of the object code with a copy of the written offer to provide the Corresponding Source. This alternative is allowed only occasionally and noncommercially, and only if you received the object code with such an offer, in accord with subsection 6b.
  • d) Convey the object code by offering access from a designated place (gratis or for a charge), and offer equivalent access to the Corresponding Source in the same way through the same place at no further charge. You need not require recipients to copy the Corresponding Source along with the object code. If the place to copy the object code is a network server, the Corresponding Source may be on a different server (operated by you or a third party) that supports equivalent copying facilities, provided you maintain clear directions next to the object code saying where to find the Corresponding Source. Regardless of what server hosts the Corresponding Source, you remain obligated to ensure that it is available for as long as needed to satisfy these requirements.
  • e) Convey the object code using peer-to-peer transmission, provided you inform other peers where the object code and Corresponding Source of the work are being offered to the general public at no charge under subsection 6d.

A separable portion of the object code, whose source code is excluded from the Corresponding Source as a System Library, need not be included in conveying the object code work.

A “User Product” is either (1) a “consumer product”, which means any tangible personal property which is normally used for personal, family, or household purposes, or (2) anything designed or sold for incorporation into a dwelling. In determining whether a product is a consumer product, doubtful cases shall be resolved in favor of coverage. For a particular product received by a particular user, “normally used” refers to a typical or common use of that class of product, regardless of the status of the particular user or of the way in which the particular user actually uses, or expects or is expected to use, the product. A product is a consumer product regardless of whether the product has substantial commercial, industrial or non-consumer uses, unless such uses represent the only significant mode of use of the product.

“Installation Information” for a User Product means any methods, procedures, authorization keys, or other information required to install and execute modified versions of a covered work in that User Product from a modified version of its Corresponding Source. The information must suffice to ensure that the continued functioning of the modified object code is in no case prevented or interfered with solely because modification has been made.

If you convey an object code work under this section in, or with, or specifically for use in, a User Product, and the conveying occurs as part of a transaction in which the right of possession and use of the User Product is transferred to the recipient in perpetuity or for a fixed term (regardless of how the transaction is characterized), the Corresponding Source conveyed under this section must be accompanied by the Installation Information. But this requirement does not apply if neither you nor any third party retains the ability to install modified object code on the User Product (for example, the work has been installed in ROM).

The requirement to provide Installation Information does not include a requirement to continue to provide support service, warranty, or updates for a work that has been modified or installed by the recipient, or for the User Product in which it has been modified or installed. Access to a network may be denied when the modification itself materially and adversely affects the operation of the network or violates the rules and protocols for communication across the network.

Corresponding Source conveyed, and Installation Information provided, in accord with this section must be in a format that is publicly documented (and with an implementation available to the public in source code form), and must require no special password or key for unpacking, reading or copying.

7. Additional Terms.

“Additional permissions” are terms that supplement the terms of this License by making exceptions from one or more of its conditions. Additional permissions that are applicable to the entire Program shall be treated as though they were included in this License, to the extent that they are valid under applicable law. If additional permissions apply only to part of the Program, that part may be used separately under those permissions, but the entire Program remains governed by this License without regard to the additional permissions.

When you convey a copy of a covered work, you may at your option remove any additional permissions from that copy, or from any part of it. (Additional permissions may be written to require their own removal in certain cases when you modify the work.) You may place additional permissions on material, added by you to a covered work, for which you have or can give appropriate copyright permission.

Notwithstanding any other provision of this License, for material you add to a covered work, you may (if authorized by the copyright holders of that material) supplement the terms of this License with terms:

  • a) Disclaiming warranty or limiting liability differently from the terms of sections 15 and 16 of this License; or
  • b) Requiring preservation of specified reasonable legal notices or author attributions in that material or in the Appropriate Legal Notices displayed by works containing it; or
  • c) Prohibiting misrepresentation of the origin of that material, or requiring that modified versions of such material be marked in reasonable ways as different from the original version; or
  • d) Limiting the use for publicity purposes of names of licensors or authors of the material; or
  • e) Declining to grant rights under trademark law for use of some trade names, trademarks, or service marks; or
  • f) Requiring indemnification of licensors and authors of that material by anyone who conveys the material (or modified versions of it) with contractual assumptions of liability to the recipient, for any liability that these contractual assumptions directly impose on those licensors and authors.

All other non-permissive additional terms are considered “further restrictions” within the meaning of section 10. If the Program as you received it, or any part of it, contains a notice stating that it is governed by this License along with a term that is a further restriction, you may remove that term. If a license document contains a further restriction but permits relicensing or conveying under this License, you may add to a covered work material governed by the terms of that license document, provided that the further restriction does not survive such relicensing or conveying.

If you add terms to a covered work in accord with this section, you must place, in the relevant source files, a statement of the additional terms that apply to those files, or a notice indicating where to find the applicable terms.

Additional terms, permissive or non-permissive, may be stated in the form of a separately written license, or stated as exceptions; the above requirements apply either way.

8. Termination.

You may not propagate or modify a covered work except as expressly provided under this License. Any attempt otherwise to propagate or modify it is void, and will automatically terminate your rights under this License (including any patent licenses granted under the third paragraph of section 11).

However, if you cease all violation of this License, then your license from a particular copyright holder is reinstated (a) provisionally, unless and until the copyright holder explicitly and finally terminates your license, and (b) permanently, if the copyright holder fails to notify you of the violation by some reasonable means prior to 60 days after the cessation.

Moreover, your license from a particular copyright holder is reinstated permanently if the copyright holder notifies you of the violation by some reasonable means, this is the first time you have received notice of violation of this License (for any work) from that copyright holder, and you cure the violation prior to 30 days after your receipt of the notice.

Termination of your rights under this section does not terminate the licenses of parties who have received copies or rights from you under this License. If your rights have been terminated and not permanently reinstated, you do not qualify to receive new licenses for the same material under section 10.

9. Acceptance Not Required for Having Copies.

You are not required to accept this License in order to receive or run a copy of the Program. Ancillary propagation of a covered work occurring solely as a consequence of using peer-to-peer transmission to receive a copy likewise does not require acceptance. However, nothing other than this License grants you permission to propagate or modify any covered work. These actions infringe copyright if you do not accept this License. Therefore, by modifying or propagating a covered work, you indicate your acceptance of this License to do so.

10. Automatic Licensing of Downstream Recipients.

Each time you convey a covered work, the recipient automatically receives a license from the original licensors, to run, modify and propagate that work, subject to this License. You are not responsible for enforcing compliance by third parties with this License.

An “entity transaction” is a transaction transferring control of an organization, or substantially all assets of one, or subdividing an organization, or merging organizations. If propagation of a covered work results from an entity transaction, each party to that transaction who receives a copy of the work also receives whatever licenses to the work the party's predecessor in interest had or could give under the previous paragraph, plus a right to possession of the Corresponding Source of the work from the predecessor in interest, if the predecessor has it or can get it with reasonable efforts.

You may not impose any further restrictions on the exercise of the rights granted or affirmed under this License. For example, you may not impose a license fee, royalty, or other charge for exercise of rights granted under this License, and you may not initiate litigation (including a cross-claim or counterclaim in a lawsuit) alleging that any patent claim is infringed by making, using, selling, offering for sale, or importing the Program or any portion of it.

11. Patents.

A “contributor” is a copyright holder who authorizes use under this License of the Program or a work on which the Program is based. The work thus licensed is called the contributor's “contributor version”.

A contributor's “essential patent claims” are all patent claims owned or controlled by the contributor, whether already acquired or hereafter acquired, that would be infringed by some manner, permitted by this License, of making, using, or selling its contributor version, but do not include claims that would be infringed only as a consequence of further modification of the contributor version. For purposes of this definition, “control” includes the right to grant patent sublicenses in a manner consistent with the requirements of this License.

Each contributor grants you a non-exclusive, worldwide, royalty-free patent license under the contributor's essential patent claims, to make, use, sell, offer for sale, import and otherwise run, modify and propagate the contents of its contributor version.

In the following three paragraphs, a “patent license” is any express agreement or commitment, however denominated, not to enforce a patent (such as an express permission to practice a patent or covenant not to sue for patent infringement). To “grant” such a patent license to a party means to make such an agreement or commitment not to enforce a patent against the party.

If you convey a covered work, knowingly relying on a patent license, and the Corresponding Source of the work is not available for anyone to copy, free of charge and under the terms of this License, through a publicly available network server or other readily accessible means, then you must either (1) cause the Corresponding Source to be so available, or (2) arrange to deprive yourself of the benefit of the patent license for this particular work, or (3) arrange, in a manner consistent with the requirements of this License, to extend the patent license to downstream recipients. “Knowingly relying” means you have actual knowledge that, but for the patent license, your conveying the covered work in a country, or your recipient's use of the covered work in a country, would infringe one or more identifiable patents in that country that you have reason to believe are valid.

If, pursuant to or in connection with a single transaction or arrangement, you convey, or propagate by procuring conveyance of, a covered work, and grant a patent license to some of the parties receiving the covered work authorizing them to use, propagate, modify or convey a specific copy of the covered work, then the patent license you grant is automatically extended to all recipients of the covered work and works based on it.

A patent license is “discriminatory” if it does not include within the scope of its coverage, prohibits the exercise of, or is conditioned on the non-exercise of one or more of the rights that are specifically granted under this License. You may not convey a covered work if you are a party to an arrangement with a third party that is in the business of distributing software, under which you make payment to the third party based on the extent of your activity of conveying the work, and under which the third party grants, to any of the parties who would receive the covered work from you, a discriminatory patent license (a) in connection with copies of the covered work conveyed by you (or copies made from those copies), or (b) primarily for and in connection with specific products or compilations that contain the covered work, unless you entered into that arrangement, or that patent license was granted, prior to 28 March 2007.

Nothing in this License shall be construed as excluding or limiting any implied license or other defenses to infringement that may otherwise be available to you under applicable patent law.

12. No Surrender of Others' Freedom.

If conditions are imposed on you (whether by court order, agreement or otherwise) that contradict the conditions of this License, they do not excuse you from the conditions of this License. If you cannot convey a covered work so as to satisfy simultaneously your obligations under this License and any other pertinent obligations, then as a consequence you may not convey it at all. For example, if you agree to terms that obligate you to collect a royalty for further conveying from those to whom you convey the Program, the only way you could satisfy both those terms and this License would be to refrain entirely from conveying the Program.

13. Use with the GNU Affero General Public License.

Notwithstanding any other provision of this License, you have permission to link or combine any covered work with a work licensed under version 3 of the GNU Affero General Public License into a single combined work, and to convey the resulting work. The terms of this License will continue to apply to the part which is the covered work, but the special requirements of the GNU Affero General Public License, section 13, concerning interaction through a network will apply to the combination as such.

14. Revised Versions of this License.

The Free Software Foundation may publish revised and/or new versions of the GNU General Public License from time to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Program specifies that a certain numbered version of the GNU General Public License “or any later version” applies to it, you have the option of following the terms and conditions either of that numbered version or of any later version published by the Free Software Foundation. If the Program does not specify a version number of the GNU General Public License, you may choose any version ever published by the Free Software Foundation.

If the Program specifies that a proxy can decide which future versions of the GNU General Public License can be used, that proxy's public statement of acceptance of a version permanently authorizes you to choose that version for the Program.

Later license versions may give you additional or different permissions. However, no additional obligations are imposed on any author or copyright holder as a result of your choosing to follow a later version.

15. Disclaimer of Warranty.

THERE IS NO WARRANTY FOR THE PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE PROGRAM “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE PROGRAM PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

16. Limitation of Liability.

IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MODIFIES AND/OR CONVEYS THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER PROGRAMS), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

17. Interpretation of Sections 15 and 16.

If the disclaimer of warranty and limitation of liability provided above cannot be given local legal effect according to their terms, reviewing courts shall apply local law that most closely approximates an absolute waiver of all civil liability in connection with the Program, unless a warranty or assumption of liability accompanies a copy of the Program in return for a fee.

END OF TERMS AND CONDITIONS

How to Apply These Terms to Your New Programs

If you develop a new program, and you want it to be of the greatest possible use to the public, the best way to achieve this is to make it free software which everyone can redistribute and change under these terms.

To do so, attach the following notices to the program. It is safest to attach them to the start of each source file to most effectively state the exclusion of warranty; and each file should have at least the “copyright” line and a pointer to where the full notice is found.

 <one line to give the program's name and a brief idea of what it does.>
Copyright (C) <year> <name of author>

This program is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation, either version 3 of the License, or
(at your option) any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with this program. If not, see <http://www.gnu.org/licenses/>.

Also add information on how to contact you by electronic and paper mail.

If the program does terminal interaction, make it output a short notice like this when it starts in an interactive mode:

 <program> Copyright (C) <year> <name of author>

This program comes with ABSOLUTELY NO WARRANTY; for details type `show w'.
This is free software, and you are welcome to redistribute it
under certain conditions; type `show c' for details.

The hypothetical commands `show w' and `show c' should show the appropriate parts of the General Public License. Of course, your program's commands might be different; for a GUI interface, you would use an “about box”.

You should also get your employer (if you work as a programmer) or school, if any, to sign a “copyright disclaimer” for the program, if necessary. For more information on this, and how to apply and follow the GNU GPL, see <http://www.gnu.org/licenses/>.

The GNU General Public License does not permit incorporating your program into proprietary programs. If your program is a subroutine library, you may consider it more useful to permit linking proprietary applications with the library. If this is what you want to do, use the GNU Lesser General Public License instead of this License. But first, please read <http://www.gnu.org/philosophy/why-not-lgpl.html>.


Systémové požadavky

Infra Recorder
Systémové požadavky

Infra Recorder má následující systémové požadavky:

  • Windows 98 s Internet Explorerem 5.0 nebo novějším.
  • 32 MiB RAM.
  • 8.1 MiB volného místa na pevném disku.


Quick Start

Infra Recorder
Quick Start

Jak na to?

Začínáme
Multisession disky
Kopírování datových disků
Kopírování audio disků
Mazání přepisovatelných disků
Zobrazení informací o disku
Nastavení mechanik


Copyright

Infra Recorder
Copyright

Infra Recorder copyright © 2006-2009 Christian Kindahl.

Infra Recorder pracuje ve spolupráci s následujícími programy:

  • cdrecord © 1995-2006 Jörg Schilling.
  • readcd © 1987, 1995-2006 Jörg Schilling.
  • cdda2wav od Project MODE a Fraunhofer Institut für integrierte Schaltungen.


Poděkování

Infra Recorder
Poděkování

Infra Recorder používá ikony a grafické prvky odvozené z Tango Icon Project. Veškerá díla odvozená z ikon projektu Tango mohou být samostatně stažena (pod licencí kompatibilní s licencí Creative Commons Attribution Share) z oficiální domovské stránky Infra Recorderu.


Co je nového

Infra Recorder
Co je nového?

Verze 0.50.0.0

  • Volnější výchozí nastavení projektu pro ISO9660.
  • U dialogů průběhu jde nyní pro větší čitelnost změnit velikost.
  • Pro déletrvající operace přidána signalizace činnosti pomocí kurzoru.
  • Opravena chyba způsobující, že byly některé neúspěšně vykonané operace považovány za úspěšné.
  • Opravena chyba ke které docházelo při kontrole disku s jednoznakovými názvy souborů nebo adresářů.
  • cdrtools aktualizovány na verzi 2.01.01a61.
  • Přidána podpora pro zobrazení BluRay a HD-DVD funkcí podporovaných mechanikou.
  • Problém se zobrazováním tlačítka OK by měl být odstraněn.
  • Značně zvýšena rychlost detekce zařízení, zařízení budou nyní vyhledávána při každém spuštění.
  • Opravena chyba která bránila odebrání zaváděcích obrazů z projektu.
  • Formát projektů InfraRecorderu pozměněn tak, aby neuchovával údaje o velikosti souborů, které mohly potenciálně způsobit chybu zápisu.
  • Přidán bezpečnostní kód který by měl při neopravitelných chybách čtení během vypalování zajistit integritu ostatních souborů.
  • InfraRecorder upraven tak aby při vytváření systému souborů uzamykal soubory na pevném disku a předešel tak inkonzistenci dat.
  • Přidána podpora pro import dat ze seznamů souborů jako je např. M3U.
  • Přidány parametry pro příkazový řádek umožňující výběr typu projektu a média.
  • Opravena chyba způsobující nefunkčnost otevření projektu prostřednictvím asociace pokud byla povolena úvodní obrazovka.
  • Do dialogu pro výběr stop přidána možnost označení všech stop pomocí Ctrl+A.
  • Kromě názvu CD/DVD mechaniky je nyní zobrazováno i její přiřazené písmeno.
  • Fixace disku přejmenována na uzavření disku (v češtině už to tak bylo od začátku).
  • Opraveny chyby související s detekcí přiřazených písmen mechanik.

Verze 0.46.2.0

  • Opravena chyba způsobující na některých systémech zatuhnutí při vytváření systému souborů disku (tentokrát už opravdu).
  • Opravena chyba způsobující nepoužití uživatelsky nastaveného dočasného adresáře.
  • Opravena chyba maximalizace při spuštění.

Verze 0.46.1.0

  • Opravena chyba způsobující na některých systémech zatuhnutí při vytváření systému souborů disku.

Verze 0.46.0.0

  • Menší opravy a aktualizace.
  • Přidána podpora pro vypalování více kopií.
  • Do hlavního programu InfraRecorderu přidána úvodní obrazovka a odstraněna samostatná express aplikace.
  • Opravena chyba způsobující, že po vymazání/zformátování disku nebylo povoleno tlačítko OK.
  • Veškerý kód je nyní pod GPL verze 3.
  • Místo programů balíku cdrtools jsou nyní použity jejich alternativy z cdrkit.
  • Vylepšena detekce mechanik, již by neměli být problémy s nesprávně přiřazenými písmeny jednotek.
  • Přidán indonéský překlad (Andhika Padmawan)!
  • Přidán chuvashský překlad (Vladimir Kozhevnikov)!
  • Opravena chyba způsobující, že nebyla přeložena express aplikace a rozšíření průzkumníka.
  • Přenosná verze InfraRecorderu nyní ukládá záznamy do adresáře programu.

Verze 0.45.0.0

  • cdrtools aktualizovány na verzi 2.01.01a38.
  • Opravena chyba způsobující pád InfraRecorderu při pokusu o přesunutí adresáře do sebe sama.
  • Opravena chyba způsobující otevření nesprávného adresáře při poklepání na adresář v projektu, pokud projekt obsahoval více adresářů se stejným názvem.
  • Opravena chyba způsobující, že po vykonání operace nebyl v dialogu průběhu navrácen fokus na tlačítko OK.
  • Opraveno chybné zobrazení ikon ve Windows XP a novějších pokud je nastavena nižší než 32-bitová hloubka barev.
  • Kontrola nastavení zařízení při spuštění je nyní ve výchozím nastavení zapnuta.
  • Přidána podpora pro asociaci InfraRecorderu s obrazy disků.
  • Pokud jsou nyní některá dialogová okna otevřena externí aplikací (např. irExpress), jsou viditelná v panelu úloh a jsou minimalizovatelná.
  • Opravena chyba způsobující, že při kontrole vypálených disků jsou použity chybné názvy souborů.
  • Přidána funkcionalita pro odstranění a přejmenování souborů z importovaných sekcí.
  • Přidána podpora pro výběr importované stopy multisession disku.
  • Při vypalování na neprázdný přepisovatelný disk se nyní InfraRecorder zeptá, zda má být vymazán.
  • Průběh operací je nyní zobrazován i ve stavovém řádku.
  • Sníženy nároky na paměť při práci s projekty.
  • Opravena chyba způsobující neschopnost otevřít projekty bez souborů.
  • Přidán thajský překlad (Prasit Kaephukhieo)!
  • Zlepšena kompatibilita se standardem ISO9660.
  • Přidána podpora pro vytváření samostatného UDF systému souborů.
  • Přidána podpora pro Unicode názvy souborů v systémech souborů Joliet a UDF.
  • V ISO9660 level 3 přidána podpora pro fragmentované soubory. Soubory větší než 4 GiB nyní mohou být vypalovány jako ISO9660.
  • Odstraněna závislost na mkisofs a isoinfo.
  • Opraveny chyby týkající se importu sekcí.
  • Do kontextové nabídky kořenové složky projektu přidána volba Vlastnosti.
  • Přidáno správné označování skrytých souborů při vytváření systému souborů.
  • Pro multisession projekty změněna výchozí metoda zápisu na TAO.
  • Opravena chyba způsobující pád InfraRecorderu při pokusu o přejmenování projektových souborů na název obsahující lomítko nebo zpětné lomítko.
  • Do seznamu podporovaných formátů obrazů disků přidána přípona .img.
  • Několik kosmetických změn.
  • Přidán arabský překlad (Circoficus)!
  • Přidán řecký překlad (Σταμάτιος Η. Σταματέλλος)!

Verze 0.44.1.0

  • Přidán alternativní způsob zjišťování podporovaných rychlostí zápisu. Tato změna řeší problém "zakázané tlačítko OK".
  • Spuštění kontroly disku nyní podporuje notebookové mechaniky (mechaniky, které nemohou sami načíst CD).
  • Opravena chyba způsobující chybné zobrazení verze v záznamech.

Verze 0.44.0.0

  • Přidáno varování při zakázání uzavření disku, protože někteří uživatelé si myslí, že takto vytvoří multisession disk.
  • Přidána podpora pro vytvoření kopie disku s použitím jedné mechaniky (stejná mechanika jako zdroj i cíl).
  • Aktualizovány funkce pro detekci rychlostí, detekce by měla nyní zobrazit podporované rychlosti podle typu vloženého média.
  • Vylepšena detekce vložení/vyjmutí média.
  • Přidána podpora pro procházení mezi jednotlivými ovládacími prvky hlavního dialogu pomocí tabulátoru.
  • Opravena chyba způsobující pád InfraRecorder na systémech s Windows 9x při změně adresáře v Průzkumníku.
  • Přidána tlačítka pro označení všech souborů a pro otočení výběru.
  • Opravena chyba způsobující v některých případech zobrazení záporného průběhu.
  • InfraRecorder by se měl nyní spouštět maximalizovaný, pokud byl jako maximalizovaný ukončen.
  • Do dialogu O programu přidáno tlačítko pro otevření domovské stránky.
  • Opravena chyba přejmenování souboru projektu.
  • Přidána podpora pro přizpůsobení tlačítkového panelu.
  • Vylepšena práce se soubory projektu, nejsou povoleny duplicitní adresáře nebo soubory.
  • Nastavení programu je nyní ukládáno do adresáře programu. Byla vytvořena nová přenosná verze InfraRecorderu, která ukládá do adresáře programu i ostatní data.
  • Výrazně vylepšena podpora přetahování myší.
  • Přidán norský překlad (Karol Ptasinski)!
  • Aktualizována nápověda, přidán rejstřík a podpora hledání.
  • Opravena chyba způsobující, že InfraRecorder se snažil kontrolovat soubory importované z předchozí sekce.
  • Opravena chyba způsobující vysunutí disku (pokud bylo povoleno) před spuštěním kontroly disku.
  • Opravena chyba způsobující nekompatibilitu se systémy s Windows 9x z důvodu volání funkce SHGetFolderPathA.

Verze 0.43.1.0

  • Nástroje cdrtools aktualizovány na verzi 2.01.01a26.
  • Přidán finský překlad (Rami Aalto)!
  • Opraveno chybové hlášení týkající se ckEffects.exe.
  • Vylepšena funkce mazání, která nyní podporuje více vypalovaček.
  • Opravena chyba způsobující neuložení velikosti a pozice hlavního okna.
  • Opravena chyba způsobující zbělení seznamu souborů Průzkumníka při poklepání na adresář (jen Windows XP).
  • Vylepšeno ukládání záznamů.
  • Opravena chyba znemožňující importování sekcí z určitých typů disků.
  • Vylepšen výkon Průzkumníka. Rozbalení položky "Tento počítač" mohlo trvat velmi dlouhou dobu v důsledku pomalých dotazů zasílaných disketovým jednotkám.

Verze 0.43.0.0

  • Opravena chyba způsobující výjimku při řazení stop audio disku.
  • Přidán kouřový efekt při vypalování (vyžaduje Windows Vista a povolené Aero).
  • Opraveno několik chyb způsobujících zobrazení chybných informací v dialogu Informace o disku.
  • Různá přizpůsobení pro Windows Vista.
  • Přidána podpora pro vhazování souborů do stromové struktury projektu.
  • Kompletně přepsán kód mazání/formátování disků. Vylepšena podpora DVD±RW a DVD-RAM.
  • Přidán katalánský překlad (Josep Lluís Amador Teruel)!
  • Přidán galicijský překlad (Xesús Estévez)!
  • Opravena chyba způsobující uložení chybných koordinátů okna InfraRecorderu pokud byl ukončen minimalizovaný.
  • Přidán rumunský překlad (Nicolae Crefelean)!
  • Odstraněna závislost rozšíření průzkumníka na C++ 8 DLL knihovnách.
  • Přidán maďarský překlad (Tibor Sárkány)!
  • Přidán hebrejský překlad (Shemesh)!
  • Přidán dánský překlad (Patrick Fust)!
  • Opravena chyba způsobující selhání vykonání interních SCSI příkazů v x64 verzi InfraRecorderu.

Verze 0.42.1.0

  • MSI instalátor pro x64 verzi nyní vytváří zástupce v podadresáři nabídky Start.
  • Opravena chyba způsobující pád InfraRecorderu pokud cdrecord oznámil vypalování stopy s číslem vyšším než byl počet stop k vypálení.
  • Odstraněna závislost irWave kodeku na Visual C++ 8 DLL knihovnách.
  • Opravena chyba způsobující poškození haldy při použití irWMA kodeku.

Verze 0.42.0.0

  • 64-bitová (x64) verze.
  • Nový Wave kodek bez závislosti na libsndfile s podporou kompilace pro x64.
  • Upraven podpůrný kód pro překlad tak, aby se mohli ovládací prvky přizpůsobit svou velikost a polohu délce přeloženého řetězce.
  • Různé změny pro zlepšení kompatibility s Windows Vista.
  • WMA kodek upraven tak aby nezobrazoval chybu pokud se nezdaří jeho načtení (pokud není nainstalován Windows Media Player).
  • Přidán japonský překlad (Nardog)!
  • Opravena chyba způsobující, že DVD byla vypalována vždy nejvyšší rychlostí.
  • Přidán korejský překlad (Jung Jin-ho)!
  • Přidán bulharský překlad (Iliyan Popov)!
  • Samostatné typy projektů pro datová DVD a CD.
  • Přidána podpora pro vynechání čísel verzí u názvu souborů v ISO9660.
  • Přidána podpora pro Rock Ridge bez nutnosti použít Joliet.
  • Opravena chyba způsobující, že u některých mechaniky nebyly zobrazovány správné rychlosti.
  • Přidána podpora pro řazení sloupců.
  • Přidána podpora pro řazení audio stop pomocí přetahování myší.
  • Přidán srbský [v cyrilice a latince] překlad (ozzii)!
  • Přidána podpora pro automatickou kontrolu disku po jeho vypálení.
  • Popisy na dialogu průběhu jsou nyní double buffered aby se zabránilo jejich poblikávání.
  • Opravena chyba způsobující chybnou detekci znakové stránky cp1250 na českých systémech.
  • Přidána podpora pro vytváření DVD-Video projektů.
  • Přidán slovenský překlad (Marek)!
  • Opravena chyba způsobující problémy s importem některých sekcí multisession disků.
  • Opravena chyba způsobující chybné nastavení výchozích voleb UDF při vytváření nového projektu.
  • Opravena chyba způsobující špatné zobrazení chybových dialogů při vypalování on the fly.
  • Přidán čínský [tradiční] překlad (Charlie)!

Verze 0.41.0.0

  • Opravena chyba způsobující chybné zobrazení velikosti ukazatele zaplnění po vložení audio souborů do mixed-mode projektu.
  • Kvůli omezením Microsoft Windows 9x Unicode Layer je vydána samostatná ne-unicode verze InfraRecorderu.
  • Přidána podpora pro zakázání zobrazení chybových hlášení pokud se nepodaří načíst některý z kodeků.
  • Přidána podpora pro vytváření DVD-Video kompatibilního systému souborů.
  • Přidána podpora pro UDF.
  • Přidána podpora pro vytváření bootovacích disků.
  • Opravena chyba bránící správnému načtení některých projektů.
  • Přidán bosenský překlad (Asim Husanovic)!
  • Přidána možnost změnit detekovanou maximální rychlost zápisu mechaniky.
  • Změněna správa rychlostí zápisu, umožňuje nyní použít větší počet rychlostí zápisu.
  • Do rozšířených informací o mechanice přidány podporované režimy zápisu.
  • Opravena chyba způsobující chybnou detekci znakové sady na systémech používajících kódovou stránku 1251.
  • Opravena chyba způsobující nastavení chybných unix oprávnění souborů u projektů používajících rozšíření Joliet.
  • Vylepšen ukazatel velikosti projektu.
  • Přidána podpora pro záznam projektů on the fly.
  • Opravena chyba kvůli které nebyl odstraněn dočasný soubor při kopírování disku.
  • Přidána možnost zakázat chybové hlášení upozorňující na výběr nepodporované znakové sady.
  • Opravena chyba způsobující, že se u projektu audio disku v tipu ukazatele velikosti zobrazovala velikost v bytech místo v minutách.
  • Přidán slovinský překlad (Frani Žižek)!
  • Přidán ukrajinský překlad a nápověda (Serhij Dubyk)!
  • Pokud je popis funkce v dialogu rozšířených informacích o mechanice příliš dlouhý než aby mohl být normálně zobrazen, zobrazí se po najetí myši ve formě tipu.
  • Opravena chyba způsobující, že byly při záznamu projektů ignorovány prázdné adresáře.
  • Opravena chyba způsobující chybu při vytváření obrazu disku, pokud některý ze souborů obsahoval znak rovnítka.
  • Přidán portugalský (brazilský) překlad (Éder Silva)!
  • Přidán čínský (zjednodušený) překlad (DouDeHou)!
  • Přidáno více možností čtení (ignorovat chyby čtení, načíst subkanálová data a TOC, rychlost čtení).
  • Přidána podpora pro klonování disků.
  • Přidána možnost změnit velikost vyrovnávací paměti FIFO.
  • Přidána podpora pro ISO level 4, který mimo jiné umožňuje větší než osmiúrovňové vnoření adresářů.

Verze 0.40.0.0

  • Přidán český překlad (khagaroth)!
  • Vylepšena podpora DVD (cdrtools mají od verze 2.01.01a09 oficiální podporu DVD).
  • Simulace nyní funguje i při záznamu na DVD.
  • Podpora mazání DVD+RW médií (aktuálně pouze pro mechaniky Ricoh).
  • Velikost a pozice okna při zavření Infra Recorderu je nyní ukládána a obnovena při příštím spuštění.
  • Přidán baskický překlad (David García-Abad)!
  • Přidána podpora převodu zvukových stop do formátu Ogg, WMA a MP3 (vzhledem k problémům s patenty v samostatném balíčku).
  • Opravena chyba způsobující během vyhledávání chyb na disku zobrazování špatných stop.
  • Přidána podpora pro dekódování MP3, Ogg a WMA.
  • Přidána německá nápověda (CE4)!
  • Přidán italský překlad (Lorenzo Festa)!
  • Opravena chyba u dialogů zpráv, měly by být nyní modální.
  • Přidána podpora pro lokalizovanou nápovědu.
  • Simulace je ve výchozím nastavení vypnuta.
  • Přidána volba umožňující nastavení pracovního adresáře.
  • Do nápovědy přidány informace o tom jak používat bezobslužnou instalaci Infra Recorderu.
  • Instalátor nyní přidává položku do seznamu Přidat/Odebrat programy.
  • Přidána možnost volby jazyka při bezobslužné instalaci.
  • Přidán ruský překlad (Roman Starikh)!
  • Přidán německý překlad (Thomas Bigler)!
  • Přidán polský překlad (DJD)!
  • Přidán turecký překlad (Fatma Akarslan)!
  • Přidán chorvatský překlad (Tibor Keser)!
  • Přidán holandský překlad (Patrick)!

Verze 0.31.0.0

  • Přidán portugalský překlad (Cesar Baptista)!
  • Přidán španělský překlad (Eduardo Leon)!
  • Zvětšena výška všech comboboxů v GUI, aby se odstranilo zbytečné rolování.
  • Opraveno několik chyb v GUI, kvůli kterým se u některých grafických prvků zobrazovalo černé nebo fialové pozadí (pouze systémy starší než Windows XP).
  • K měřítku zaplnění přidán tip zobrazující velikost projektu.
  • Přidána podpora pro vkládání souborů z Průzkumníka Windows do projektu.
  • Opravena chyba umožňující do projektu naimportovat více sekcí.

Verze 0.30.0.83

  • Opravena chyba (statické slinkování s UpdateLayeredWindow v user32.dll) způsobující nekompatibilitu s Windows9x.

Verze 0.30.0.82 (Beta 2)

  • Pomocí patche pro cdrecord přidána podpora pro DVD (VAROVÁNÍ: Při vypalování DVD nefunguje simulace).
  • Přidán francouzský překlad (Pierre-Jean Coudert)!
  • Kvůli kompatibilitě s DVD byla výchozí metoda zápisu změněna na SAO.
  • Do instalátoru byly přidány nové volby a podpora pro více jazyků.
  • Přidáno několik nových přeložitelných řetězců pro výstup záznamu událostí.
  • Provedeny změny v adresářové struktuře CVS.


Instalace

Infra Recorder
Instalace

Instalátor Infra Recorderu podporuje parametry pro bezobslužnou instalaci. Instalátoru mohou být předány následující parametry (pozor, musí být dodržena velikost písmen):

/S
Spustí instalátor (nebo odinstalátor) v tichém režimu. U všech voleb, které nebudou změněny zadáním dodatečných parametrů budou použity výchozí hodnoty.

/LANGUAGE=<jazyk>
Určí jazyk, který má Infra Recorder Použít. Například: "irsetup.exe /S /LANGUAGE=swedish" provede tichou instalaci Infra Recorderu s výchozím jazykem nastaveným na švédštinu.


FAQ (Často kladené otázky)

InfraRecorder
FAQ

Pro aktuální seznam často kladených otázek navštivte http://infrarecorder.org.

InfraRecorder nevidí mé mechaniky, jak tento problém vyřešit?
S největší pravděpodobností jde o problém s oprávněním. Ve výchozím nastavení používá InfraRecorder k přístupu k mechanikám rozhraní SPTI. V systémech Windows 2000, XP a 2003 jsou pro použití SPTI vyžadována administrátorská oprávnění.

Pokud chcete povolit omezeným účtům přístup k mechanikám pomocí SPTI, přihlašte se jako administrátor a postupujte podle následujícího návodu:

  1. Otevřete nabídku "Start" a klepněte na možnost "Spustit".
  2. Zadejte příkaz "secpol.msc" (bez uvozovek) a potvrďte tlačítkem OK.
  3. Přejděte do klíče "Místní zásady" -> "Možnosti zabezpečení".
  4. Změňte "Zařízení: Omezit přístup k jednotce CD-ROM pouze na místně přihlášené uživatele" ze "Zakázat" na "Povolit".

Některé verze Windows neobsahují "secpol.msc" (např. Windows XP Home). Pokud takový systém používáte, postupujte následujícím způsobem (nezapomeňte se přihlásit jako administrátor):

  1. Otevřete nabídku "Start" a klepněte na možnost "Spustit".
  2. Zadejte příkaz "regedit" (bez uvozovek) a potvrďte tlačítkem OK.
  3. Přejděte do klíče "HKEY_LOCAL_MACHINE" -> "SOFTWARE" -> "Microsoft" -> "Windows NT" -> "CurrentVersion" -> "Winlogon".
  4. V zadaném klíči vytvořte novou řetězcovou hodnotu s názvem "allocatecdroms" a přiřaďte jí hodnotu "1" (bez uvozovek). Pokud již daná řetězcová hodnota existuje a je nastavena na hodnotu "0", jednoduše ji změňte na "1".


Začínáme

Jak na to?, Práce s projekty
Začínáme

Toto téma vám pomůže při vytváření vašeho prvního CD projektu. Infra Recorder v současné době podporuje tři typy projektů.

Datový disk - tento typ projektu je použit k vytvoření disku, který obsahuje soubory a složky (je použit systém souborů ISO9660) a je kompatibilní s téměř všemi počítači. Datové disky neobsahují v jednom sektoru tolik dat jako audio disky, protože kromě samotných dat jsou na datových discích uložena také dodatečná kontrolní/opravná data. Díky tomu mohou být datové disky vypalovány větší rychlostí aniž by hrozilo znatelné snížení kvality nebo dokonce ztráta dat. Datové disky mohou být vytvářeny postupně, lze přidávat data na již jednou vypálený disk. Více informací je uvedeno v tomto tématu.

Audio disk - tento typ projektu je použit k vytvoření audio disku, který bude možné přehrát v libovolném CD přehrávači (a počítači). Vypalování audio disků by mělo probíhat nižší rychlostí, protože audio disky neobsahují kontrolní/opravná data.

Mixed-Mode CD - tento typ projektu je použit k vytvoření disku, jehož první datová stopa má stejné vlastnosti jako datový disk a za ní poté následuje několik audio stop. Mixed-Mode CD je možné přehrát v libovolném CD přehrávači, ale první (datová) stopa bude přehrávána jako šum, další stopy už budou přehrány normálně.

Pro vytvoření nového projektu použijte nabídku:
Soubor [image] Nový projekt [image] <typ projektu který chcete vytvořit>
Pro otevření existujícího projektu pak použijte nabídku:
Soubor [image] Otevřít projekt...
nebo tlačítko:

Projekty InfraRecorderu mohou být přímo zapsány na CD, nebo z nich může být vytvořen obraz disku. Obraz disku je soubor obsahující všechny soubory, které jste přidali do projektu (s vyjímkou audio stop Mixed-Mode a Audio projektů) a údaje o struktuře disku. Obraz může být později vypálen na CD. Více informací v tomto tématu.

Pro vypálení projektu na CD můžete použít nabídku:
Akce [image] Zapsat kompilaci [image] vypálit na CD...
nebo tlačítko:

Podrobný popis možností vypalování získáte v tomto tématu.

Prostředí

Obecné

Panel nástrojů Průzkumník slouží k pohybu v okně průzkumníka a k přidání souborů vybraných v okně průzkumníka do vašeho projektu.
Panel nástrojů Struktura disku pak slouží k procházení vašeho projektu a správě přidaných souborů.

Správa souborů

Nabídka Úpravy slouží ke správě souborů projektu:
Výše uvedené možnosti jsou pro rychlejší přístup dostupné také jako kontextová nabídka při klepnutí pravým tlačítkem myši do okna projektu. Pokud např. klepnete v okně projektu pravým tlačítkem na adresář, objeví se tato nabídka:
Pokud do vašeho projektu přidáte více souborů, než se vejde na vybraný typ média, ukazatel zaplnění disku zčervená:
Ukazatel zaplnění bude oranžový, pokud přidáte více dat, než kolik se na vybraný typ média normálně vejde, ale pravděpodobně bude možné data úspěšně vypálit pokud povolíte overburning:

Velikost ukazatele zaplnění můžete změnit podle typu média na které se chystáte projekt vypálit. To uděláte tak, že na ukazatel klepnete pravým tlačítkem a z kontextové nabídky vyberete příslušný typ média.

Správa souborů

Přidání souborů

Existuje několik způsobů jak přidat soubory do vašeho projektu. Můžete použít přetažení myší z interního Průzkumníka nebo z Průzkumníka Windows. V interním Průzkumníku můžete také pouze označit soubory, které chcete přidat a poté použít nabídku:

Úpravy [image] Přidat [image] Označené
nebo tlačítko panelu Průzkumníka:

V interním Průzkumníku také můžete přejít do určitého adresáře a jednoduše přidat všechny jeho soubory a podadresáře.

Pro přidání všech souborů a podadresářů aktivního adresáře otevřeného v okně Průzkumníka můžete použít nabídku:
Úpravy [image] Přidat [image] Vše
nebo tlačítko panelu Průzkumníka:

Odstranění souborů

Také při odstranění souborů z projektu máte na výběr z několika postupů. Jednou z možností je použití tlačítka Delete na vaší klávesnici, nebo můžete použít příslušnou položku nabídky, případně tlačítko na panelu.

Pro odstranění souborů pomocí nabídky použijte:
Úpravy [image] Odstranit
případně použijte tlačítko na panelu Struktura disku:

Ostatní operace

Pro přejmenování souboru nebo adresáře použijte nabídku:
Úpravy [image] Přejmenovat
nebo tlačítko na panelu Struktura disku:
Pro přidání prázdného adresáře použijte nabídku:
Úpravy [image] Nový adresář
nebo tlačítko panelu Struktura disku:


Multisession disk

Jak na to?, Práce s projekty
Multisession disk

Multisession disk je disk obsahující více sekcí. Může být vypalován postupně sekce za sekcí.

Vytvoření nového multisession disku

Vytvoření nového multisession disku je jednoduché. Pro vytvoření nového multisession disku vytvořte nový datový projekt:
Soubor [image] Nový projekt [image] Datové CD
Otevřete nastavení projektu:
Soubor [image] Vlastnosti projektu...
Vyberte záložku ISO a změňte Formát na:
Mode 2 XA (multisession)
Případně můžete projekt vytvořit pomocí nabídky:
Soubor [image] Nový projekt [image] Datové CD (multisession)
, která potřebná nastavení provede za vás.

Nyní můžete přidávat soubory a adresáře jako do běžného projektu. Pro více podrobností o práci s projekty si přečtěte toto téma.

Navázání multisession disku

Pro přidání dat na existující multisession disk musíte do vašeho projektu naimportovat data existující sekce. Použijte nabídku:
Akce [image] Importovat sekci...

Objeví se okno s možností výběru mechaniky a s informací o obsazeném a volném místu na CD. Pokud je tlačítko OK neaktivní, znamená to, že disk nelze naimportovat.

Poté, co vyberete mechaniku obsahující multisession disk, který chcete naimportovat, klepněte na tlačítko OK a data budou naimportována do vašeho projektu. Naimportovaná data nemohou být upravována ani smazána. Všechny naimportované soubory a adresáře jsou proto zobrazeny šedivým textem.

Poté co skončíte s úpravami projektu, zapište změny na disk pomocí nabídky:
Akce [image] Zapsat kompilaci [image] vypálit na CD...
nebo pomocí tlačítka:


Vlastnosti projektu

Jak na to?, Práce s projekty
Vlastnosti projektu
Toto téma se zabývá možnostmi dostupnými z nabídky:
Soubor [image] Vlastnosti projektu...

Obecná nastavení

Jediné obecné nastavení, které můžete změnit je název CD. Jako výchozí název je použit datum a čas vytvoření projektu. Na název CD se vztahují stejná omezení jako na názvy souborů (viz Možnosti ISO).

Možnosti ISO

Úroveň

Tato volba nastavuje úrovně normy ISO určující omezení týkající se hlavně názvů souborů a hloubky adresářové struktury. InfraRecorder podporuje tři úrovně:

  1. Level 1 povoluje jen názvy v 8.3 formátu (osm znaků pro název a tři znaky pro příponu), velká písmena, čísla a podtržítka. Maximální hloubka adresářové struktury je osm úrovní.
  2. Level 2 povoluje názvy s až 31 znaky.
  3. Level 3 povoluje fragmentované soubory (umožňuje paketový zápis a inkrementální vypalování).
  4. Level 4 v podstatě neexistuje, ale pokud je vybrán, je použit standard ISO-9660:1999 (ISO-9660 verze 2). Tento standard povoluje názvy souborů s až 207 znaky a adresářovou strukturu s hloubkou větší než osm úrovní.

Formát

Tato volba určuje formát, který má být použit při zápisu dat na CD. Formát Mode 1 je používaný při vytváření běžných disků, zatímco formát Mode 2 by měl být použit při vytváření multisession disků. Mode 1 umožňuje uložit 2048 bytů dat na sektor, Mode 2 pak 2336 bytů (CD-ROM sektor má velikost 2352 bytů).

Ostatní volby

Povolit u názvů rozšíření Joliet přidá na disk kromě názvů v ISO9660 adresářové záznamy rozšíření Joliet. Rozšíření Joliet se běžně používá ve Windows a povoluje UNICODE názvy s maximální délkou 64 znaků.

Pokud chcete použít ještě delší názvy souborů, můžete povolit volbu Pro Joliet názvy povolit více než 64 znaků. Tato volba není kompatibilní se specifikací Joliet, ale funguje. Maximální délka názvu je rozšířena na 103 znaků.

Popisky

Tato sekce umožňuje zadat informace o projektu. Pole Vydavatel, Připravil, Systém a Sada disků obsahují přímo dané informace, ostatní pole z důvodu omezené délky (36 znaků) často obsahují jen názvy souborů s příslušnými informacemi.

Nastavení audia

Tato sekce umožňuje zadat informace CD-Textu. CD-Text je formát umožňující zadat informace o jménu autora, názvu CD a stop, které pak mohou být zobrazeny během přehrávání. Dostupné pouze v audio a mixed-mode projektech.

Nastavení spuštění

Tato sekce je dostupná pouze pro datové projekty a umožňuje zadat až 63 zaváděcích obrazů, které budou použity k vytvoření spouštěcího CD. Pro přidání zaváděcího obrazu použijte tlačítko Přidat nový zaváděcí obraz:


Přidání zaváděcího obrazu

Jak na to?, Práce s projekty
Přidání zaváděcího obrazu

Existuje několik voleb, které budete muset nastavit při přidání zaváděcího obrazu do vašeho projektu.

Typ emulace

Tato volba umožňuje určit typ emulace použité pro daný "El Torito" disk. Pokud je nastavena emulace Diskety, musí mít zaváděcí obraz přesně velikost 1200, 1440 nebo 2880 KiB diskety. Pokud je nastavena emulace Pevného disku, musí zaváděcí obraz začínat hlavním zaváděcím záznamem obsahujícím přesně jeden diskový oddíl. Je také možné načíst zaváděcí obraz bez jakékoliv emulace.

Pokročilé možnosti

NEnastavit disk jako spustitelný - bude přidán zaváděcí obraz, ale nebude označen jako spustitelný. Systém bude pro obraz emulovat disk, ale spustí se ze standardního spouštěcího zařízení.

Zaváděcí segment - umožňuje nastavit adresu zaváděcího segmentu (hexadecimálně) pro neemulované "El Torito" disky.

Počet zav. sektorů - umožňuje určit počet (hexadecimálně) virtuálních (512-bytových) sektorů, které se mají načíst v neemulovaném režimu. Je doporučeno načíst celý zaváděcí soubor. Některé BIOSy moho mít problémy, pokud velikost není násobkem 4.


Vypálení obrazu

Jak na to?
Vypálení obrazu
Pro vypálení obrazu disku můžete použít nabídku:
Akce [image] Vypálit obraz...
nebo tlačítko:

Bude zobrazen dialog pro výběr obrazu disku, který chcete vypálit.

Nastavení

Detailní popis všech dostupných nastavení naleznete v tomto tématu.


Možnosti vypalování

Jak na to?
Možnosti vypalování

Toto téma se zabývá různými volbami nastavení vypalování se kterými se můžete setkat v InfraRecorderu, pokud chcete např. vypálit kompilaci, obraz disku, nebo kopii disku.

Přestože jsou tyto volby přístupné v různých kontextech, jak uvedeno výše, jsou vždy prezentovány stejně:

Obecná nastavení

On the fly

Při vypalování on the fly je systém souborů vytvářen během vypalování, což může zvýšit pravděpodobnost výskytu chyb. Pokud je tato volba zakázána, bude před vypalováním na disku vytvořen dočasný obraz disku, který pak bude vypálen. Doporučené nastavení je "vypnuto", tato volba by obecně měla být povolena pouze pokud máte nedostatek volného místa na disku.

Po vypálení zkontrolovat disk

Po povolení této volby InfraRecorder po vypálení disku provede porovnání CRC souborů na vašem pevném disku se soubory vypálenými na CD, aby ověřil, zda byly soubory vypáleny správně.

Rychl. zápisu

Volba rychlosti kterou má být disk vypálen. Volba Maximální automaticky vybere nejvyšší rychlost podporovanou vaší vypalovačkou a vloženým médiem.

Metoda zápisu

Toto volba určuje metodu použitou k vypálení disku. Budou dostupné pouze volby, které podporuje vaše vypalovačka.

Session-At-Once (SAO) nebo také Disc-At-Once (DAO), zapisuje všechna data (včetně lead-in a lead-out) najednou. Nepovoluje přerušení datového toku. Nelze přidávat další stopy/sekce. DVD musí být vždy zapsána touto metodou.

Track-At-Once (TAO) zapisuje každou stopu samostatně, což vyžaduje spojovací bloky mezi stopami. Starší vypalovačky většinou vkládají 2sekundovou pauzu (pregap) mezi stopy, novější vypalovačky většinou podporují nastavení délky pregap (viz volba níže).

TAO s nulovou mezerou používá výše uvedenou metodu Track-At-Once a pokusí se nastavit délku pregap na nulu, minimalizuje tak počet spojovacích bloků mezi stopami.

Raw zápis (raw96r) zapisuje data v raw režimu s 2352 bytovými sektory plus 96 bytů raw P-W subkanálových dat s výslednou velikostí sektoru 2448 bytů. Toto je upřednostňovaná metoda zápisu umožňující nejlepší kontrolu nad procesem zápisu.

Raw zápis (raw16) zapisuje data v raw režimu s 2352 bytovými sektory plus 16 bytů P-Q subkanálových dat s výslednou velikostí sektoru 2368 bytů. Pokud vypalovačka nepodporuje raw96r raw režim, jde o upřednostňovanou metodu zápisu. Tato metoda zápisu nepodporuje CD-Text.

Raw zápis (raw96p) zapisuje data v raw režimu s 2352 bytovými sektory plus 96 bytů raw P-W subkanálových dat s výslednou velikostí sektoru 2448 bytů. Toto je nejméně doporučovaná metoda zápisu, protože ji podporuje jen malé množství vypalovaček a mnohé z těch které ji podporují obsahují chyby v její implementaci. Nepoužívejte pokud vaše vypalovačka podporuje raw96r nebo raw16.

Důležité: Raw režimy vyžadují při vypalování znatelně více procesorového času než ostatní metody zápisu. Pokud máte pomalejší procesor, můžete mít problémy s podtečením vyrovnávací paměti.

Ostatní volby

Zvolením volby Simulace způsobí, že InfraRecorder provede zadanou akci s vypnutým laserem. Tuto volbu použijte pokud si nejste jisti, zda se operace zdaří.

Ochrana proti podtečení vyrovnávací paměti je funkce většiny novějších mechanik, která umožňuje pokračovat ve vypalování i pokud došlo k podtečení vyrovnávací paměti. Tato funkce má různá jména v závislosti na výrobci dané mechaniky, např.: Yamaha Lossless-Link, Sanyo BURN-Proof, Ricoh Just-Link, atd.

Volba Přidat k datovým stopám padding po svém povolení způsobí přidání 15 sektorů obsahujících samé nuly za každou zapsanou datovou stopu a doplnění audio stop na násobky 2352 bytů. Důvodem proč byste mohli chtít povolit tuto volbu je pokud má vaše mechanika problémy se čtením posledního sektoru stopy nebo pokud chcete disk použít na Linuxu s read ahead chybou.

Zakázání volby Po vypálení uzavřít disk způsobí, že poslední sekce (SAO režim) nebo stopa (TAO režim) nebudou uzavřeny. To může být užitečné pokud chcete CD vypálit v několika krocích.

Důležité: Vytvoření neuzavřeného disku není to samé jako vytvoření multisession disku.

Pokročilá nastavení

Volba Povolit overburning vám umožní na disk zapsat více dat než je oficiální velikost média. Většina disků může pojmout více dat než je jejich oficiální velikost, protože oficiální velikost lead-out oblasti je 90 sekund (6750 sektorů) a disk většinou funguje i jen se 150 sektory lead-out. Média mohou být přepálena minimálně o 88 sekund (6600 sektorů). Většina vypalovaček podporuje overburning jen v SAO a raw režimech. Některé vypalovačky omezují možnost přepálení na určitou velikost. Tento problém můžete obejít použitím raw režimu, protože v tom případě vypalovačka zjistí velikost média až při zahájení vypalování.

Po povolení volby Prohodit pořadí bytů audio dat je u audio dat předpokládáno byte-swapped (little-endian) pořadí bytů. Některé vypalovačky např. od Yamahy, Sony a nové SCSI-3/MMC vypalovačky vyžadují zasílání audio dat v little-endian pořadí, jiné vypalovačky pak mohou vyžadovat big-endian (síťové) pořadí bytů běžné pro SCSI protokol. Pořadí bytů vyžadované vaší vypalovačkou bude detekováno automaticky. Jediný případ, kdy je třeba použít tuto volbu je pokud jsou vypalovaná data v Intel (little-endian) pořadí.

Ignorovat velikost média může být použito pokud chcete ignorovat známou velikost média. Používejte opatrně. Tato volba předpokládá overburning.

Volba Nastavit příznak SCSI IMMED nastaví u některých SCSI příkazů příznak IMMED. Nastavení příznaku IMMED požaduje okamžité navrácení příkazu zatímco operace probíhá na pozadí, umožňuje tak použití sběrnice ostatními zařízeními a brání zatuhnutí systému. To může být užitečné na systémech s ATAPI pevnými disky a CD/DVD vypalovačkami na jedné sběrnici nebo na SCSI systémech které nepoužívají disconnect/reconnect. Tyto systémy zatuhnou při mazání/uzavírání disku nebo při zaplňování sekce na plnou velikost. Ne všechny vypalovačky podporují příznak IMMED.

Yamaha Audio Master Q. R. je funkce sloužící k vytvoření vysoce kvalitních audio disků, které mají menší problémy s přehráváním v Hi-Fi přehrávačích. Jde o variantu SAO režimu, je proto funkční pouze pokud zvolíte režim Session-At-Once (SAO). Tato volba nefunguje se všemi rychlostmi vypalování a neumožňuje vypálení stejného množství dat protože pity na CD budou větší než obvykle. Pokud tuto volbu povolíte, na běžné 74minutové CD se vejde 63 minut a na 80 minutové CD pak 68 minut. Tato volba funguje i u datových disků.

Volba Forcespeed režim přinutí mechaniku použít zvolenou rychlost bez ohledu na kvalitu vloženého média. Moderní vypalovačky většinou sami poznají maximální možnou rychlost pro dané médium a pro dosažení nejlepší možné kvality mohou rychlost vypalování i snížit. Používejte opatrně. Vypalovačka většinou ví nejlépe jakou rychlost zvolit.

Režim zápisu Plextor VariRec umožňuje uživateli částečně řídit výkon laseru. Pokud nastaveno správně, může snížit jitter a zlepšit tak čitelnost a kompatibilitu s existujícími CD přehrávači. VariRec je funkční pouze při 4x rychlosti vypalování.


Možnosti čtení

Toto téma se zabývá možnostmi čtení, které budete moci nastavit v různých dialozích InfraRecorderu, např. když budete chtít zkopírovat disk ať už na na jiný disk nebo jako obraz na váš pevný disk.

Přestože jsou tyto volby přístupné v různých kontextech, jak uvedeno výše, jsou vždy prezentovány stejně:

Možnosti čtení

Ignorovat chyby čtení

Povolením této volby zakážete přerušení kopírování pokud dojde při kopírování dat k chybě. Mechanika bude také přepnuta do režimu, ve kterém ignoruje chyby při čtení sektorů, které jsou důsledkem neopravitelných ECC/EDC chyb.

Načíst subkanálová data a TOC

Pokud je tato volba povolena, budou při kopírování disku přečtena všechna subkanálová data a celá TOC. Informace TOC budou uloženy do souboru s názvem shodným s názvem souboru obrazu a s příponou .toc.

Rychlost čtení

Zde můžete vybrat rychlost jakou bude disk čten. Po výběru volby Maximum bude zvolena nejvyšší rychlost podporovaná mechanikou a vloženým médiem. Volba je funkční pouze s MMC kompatibilními mechanikami. Rychlost ne-MMC mechanik není změněna.

Snížení rychlosti můžete zlepšit čitelnost.


Kopírování audio disků

Jak na to?
Kopírování audio disků
Kopírování audio disků vyžaduje více kroků než kopírování datových disků. Nejdříve musíte audio stopy zkopírovat na pevný disk. To provedete otevřením dialogu Stopy:
Akce [image] Spravovat stopy...
Po vybrání správné mechaniky a vložení audio disku by tento dialog měl vypadat přibližně následovně:
Nyní vyberte stopy (pomocí myši, fungují běžné zkratky pro výběr - shift - výběr rozsahu a ctrl - vícenásobný výběr), které chcete uložit (zkopírovat). Po označení všech požadovaných stop, klepněte na tlačítko Uložit označené stopy:

Bude zobrazen dotaz na cílový adresář pro uložení stop. Vyberte adresář podle vlastního uvážení. Poté co vyberete cílový adresář, budou do něj uloženy všechny označené stopy (za předpokladu, že nedojde k nějaké chybě).

Dalším krokem je vytvoření nového Audio CD projektu do kterého přidáte právě uložené stopy. Více informací získáte v tomto tématu.


Kopírování datových disků

Jak na to?
Kopírování datových disků

Toto téma obsahuje údaje pouze o kopírování datových disků. Pokud chcete kopírovat audio disk (což vyžaduje úplně jiný postup), přečtěte si toto téma.

Při kopírování datových disků si můžete vybrat ze dvou možností, podle toho, zda chcete kopírovat přímo na další mechaniku (např. z čtecí mechaniky na vypalovací) nebo vytvořit obraz disku na vašem pevném disku.

Kopie na CD

Pro zkopírování disku přímo na další disk použijte nabídku:
Akce [image] Kopírovat disk [image] vypálit na disk...
nebo tlačítko:

Zdroj

Vyberte zdrojovou mechaniku, která obsahuje disk který chcete kopírovat.

Cíl

Vyberte cílovou mechaniku, která obsahuje prázdný disk na který chcete vypálit kopii. V případě, že je zvoleno vypalování On the fly, nesmí se cílová mechanika schodovat se zdrojovou mechanikou.

On the fly

Vypalování on the fly znamená, že data budou čtena ze zdrojové mechaniky a přímo zapisována pomocí zdrojové (vypalovačky) bez jakéhokoliv dočasného souboru (je použita jen relativně malá vyrovnávací paměť). Pokud dojde při čtení čtení zdrojového disku k chybě, může dojít k přerušení toku dat do vypalovačky a chybě vypalování. Většina nových vypalovaček však poskytuje nějaký typ ochrany proti podtečení vyrovnávací paměti, takže by ani v tomto případě nemělo dojít k poškození disku.

Pokud je On the fly zakázáno, bude napřed na vašem pevném disku vytvořen dočasný obraz kopírovaného disku. Tento obraz pak bude vypálen na cílový disk. Tento způsob vyžaduje více volného místa na pevném disku, ale jde o doporučený způsob vypalování.

Klonovat disk

Pokud označíte tuto volbu, budou zkopírována i subkanálová data a TOC zdrojového disku. Tato volba musí být označena při kopírování mixed-mode disků, jinak bude zkopírována jen datová stopa. Je doporučeno vypalovat v raw96r režimu. Pokud vaše vypalovačka tento režim nepodporuje, použijte raw16.

Možnosti čtení

Možnosti čtení jsou popsány v tomto tématu.

Ostatní možnosti

Ostatní možnosti jsou popsány v tomto tématu.

Vytvoření obrazu disku

Pro vytvoření obrazu disku na vašem pevném disku použijte nabídku:
Akce [image] Kopírovat disk [image] vytvořit obraz...

Zdroj

Vyberte zdrojovou mechaniku, která obsahuje disk který chcete kopírovat.

Soubor obrazu

Vyberete umístění a název souboru obrazu disku. Pro uložení obrazu budete potřebovat volné místo odpovídající přibližně velikosti kopírovaného disku.

Možnosti čtení

Možnosti čtení jsou popsány v tomto tématu.


Informace o disku

Jak na to?
Informace o disku
Pro zobrazení podrobných informací o vloženém disku použijte nabídku:
Akce [image] Informace o disku [image] <vyberte mechaniku s vloženým diskem o němž chcete získat informace>

Dostupné informace

Typ disku - typ vloženého disku, např. CD-R, DVD+R DL atd.

Book type - platný jen pro DVD, zobrazuje book type vloženého DVD.

Region - zobrazuje region vloženého DVD. Významy uvedených čísel regionu:

  1. USA, Kanada.
  2. Evropa, včetně Turecka, Egypta, Arabského poloostrova, Japonska a Jižní Afriky.
  3. Korea, Thajsko, Vietnam, Borneo a Indonézie.
  4. Austrálie a Nový Zéland, Mexiko, Karibik a Jižní Amerika.
  5. Indie, Afrika, Rusko a bývalé republiky Sovětského svazu.
  6. Čína.
  7. Nepoužit.
  8. Letecká a lodní osobní doprava.
  9. Rozšíření (často uváděno jako bez regionu).

Vrstvy - zobrazuje počet vrstev na disku.

Stopy - zobrazuje počet stop na disku.

Sekce - zobrazuje počet sekcí na disku.

Stav - zobrazuje informace o stavu disku a sekcí stejně jako informaci o tom, zda je možné disk smazat.

Využité místo - zobrazuje množství využitého prostoru na disku.

Volné místo - zobrazuje množství volného prostoru na disku.


Smazání disku

Jak na to?
Smazání disku
Pro smazání přepisovatelného disku použijte nabídku:
Akce [image] Smazat/Naformátovat disk...
nebo tlačítko:

Vypalovačka

Vyberte mechaniku, kterou chcete použít k mazání.

Metoda mazání

Vyberte jednu ze čtyř dostupných metod mazání. Smazat celý disk - zničí všechna data na disku. Tato operace může trvat dlouhou dobu. Rychlé smazání - vymaže pouze TOC, PMA a pregap. Samotná data nejsou smazána (pouze budou nedostupná), k vymazání dat dojde až když na disk vypálíte nová data. Tato metoda je velice rychlá a trvá většinou jen 10 sekund. Otevřít poslední sekci - otevře poslední sekci (na uzavřeném multisession disku) a umožní tak přidání dalších sekcí. Poslední metoda Smazat poslední sekci jednoduše smaže poslední sekci na disku. To může trvat dlouho nebo jen chvíli v závislosti na velikosti poslední sekce.

Ostatní volby

Pokud byla z nějakého důvodu poškozena TOC, InfraRecorder odmítne disk smazat pokud nepovolíte Ignorovat ilegální TOC.

Povolením volby Simulace přinutíte InfraRecorder provést požadovanou akci s vypnutým laserem. Tato volba je doporučena pokud si nejste jisti, zda operace proběhne úspěšně.


Uzavření disku

Jak na to?
Uzavření disku
Uzavřený disk je považován za dokončený. Uzavření je většinou automaticky provedeno po vypálení dat na disk. Tato funkce je k dispozici pro případy, kdy byla na disk zapsána data, ale disk nebyl z nějakého důvodu uzavřen. Pro uzavření disku použijte nabídku:
Akce [image] Uzavřít disk...

Vypalovačka

Vyberte mechaniku do které jste vložili disk, který chcete uzavřít.

Ostatní volby

Zatržením volby Simulace donutíte InfraRecorder provést požadovanou s vypnutým laserem. To je doporučeno v případě, že si nejste jisti, zda daná operace proběhne úspěšně.


Správa stop

Jak na to?
Správa stop
Volba Spravovat stopy spustí nástroj, který zobrazí TOC vloženého disku. Také nabízí možnost uložení a kontroly vybraných stop. Pro otevření správce stop použijte nabídku:
Akce [image] Spravovat stopy...

Vyberte myší stopy se kterými chcete pracovat (můžete kombinovat s klávesami shift a ctrl). Procházet seznamem a vybírat stopy můžete také pomocí šipek na klávesnici.

Při ukládání stop na pevný disk budete dotázání na cílový adresář. Stopy pak budou automaticky pojmenovány podle čísla a typu dané stopy (Stopa 1.wav, Stopa 2.iso). Pro uložení vybraných stop na pevný disk použijte tlačítko Uložit označené stopy:
Pro kontrolu vybraných stop použijte tlačítko Vyhledat v označených stopách chyby:

Snímky obrazovky

Výsledek po kontrole datové stopy:


Nastavení mechanik

Jak na to?
Nastavení mechanik
Pokud došlo ke změnám ve vaší hardwarové konfiguraci, pravděpodobně o tom budete chtít InfraRecorder informovat. Pro zobrazení nastavení mechanik použijte nabídku:
Možnosti [image] Mechaniky...

Zobrazí se seznam mechanik, které InfraRecorder našel ve vašem systému. Pokud chcete tento seznam aktualizovat, klepněte na tlačítko Znovu hledat. To spustí prohledání vašeho systému a načtení informací o všech podporovaných mechanikách.

Pokud chcete aby InfraRecorder kontroloval aktuálnost nastavení při každém spuštění, povolte volbu Při každém spuštění kontrolovat platnost konfigurace.


Nastavení

Jak na to?
Nastavení
Pro přístup k nastavení InfraRecorderu použijte nabídku:
Možnosti [image] Nastavení...

Obecná nastavení

Při spuštění zkontrolovat, zda je aktivní autorun - určuje, zda má InfraRecorder při spuštění kontrolovat zda je aktivní autorun. Je doporučeno autorun vypnout, protože pokud je zapnutý, může Windows během vypalování zaslat CD mechanice dotaz na autorun, což může způsobit selhání vypalování a znehodnocení vloženého CD.

Při spuštění zobrazit úvodní dialog - určuje, zda má být při spuštění InfraRecorderu zobrazen úvodní dialog s nabídkou dostupných činností

Asociovat InfraRecorder s .irp (InfraRecorder projekt) soubory - provede asociaci InfraRecorderu se soubory projektů InfraRecorderu (.irp soubory)

Asociovat InfraRecorder s obrazy disků (.iso, .img a .cue) - provede asociaci InfraRecorderu se soubory obrazů disků

Adresář průzkumníka - zde můžete určit adresář, který bude v integrovaném průzkumníku zobrazen jako výchozí po spuštění InfraRecorderu, zatržením volby Zapamatovat si poslední aktivní adresář také můžete určit, že bude jako výchozí nastaven adresář, který byl aktivní když jste naposledy ukončili InfraRecorder

Pracovní adresář - zde můžete nastavit adresář do kterého budou ukládány dočasné soubory, jako např. obrazy disků. Nastavte zde adresář na disku na kterém je dostatek volného místa. Ve výchozím nastavení je použit dočasný adresář vašeho systému.

Rozšířená nastavení

Povolit záznam událostí - aktivuje funkci záznamu událostí, to může být užitečné pokud dochází k chybám. Není doporučeno zapínat záznam pokud nepotřebujete zaznamenat nějakou konkrétní událost, protože po aktivaci této funkce vyžaduje InfraRecorder více paměti a výkonu procesoru.

Povolit kouřový efekt - aktivuje kouřový efekt zobrazovaný během vypalování. Tento efekt vyžaduje Windows Vista s aktivovaným Aero rozhraním. Pokud není Aero aktivní, bude toto nastavení ignorováno.

Velikost vyrovnávací paměti FIFO - umožňuje nastavit množství RAM paměti které má být použito jako dodatečná vyrovnávací paměť k vyrovnávací paměti vaší mechaniky. Větší vyrovnávací paměť může umožnit stabilnější proces vypalování. Velikost FIFO by měla být minimálně jako velikost vyrovnávací paměti vaší mechaniky a maximálně polovina dostupné volné paměti vašeho počítače. Pokud často vypalujete on-the-fly, měla by být tato vyrovnávací paměť dostatečně veliká (např. 128 MiB), zabráníte tak podtékání bufferu.

Nastavení jazyka

V rozbalovací nabídce jsou zobrazeny všechny dostupné překlady programu. Pro změnu jazyka rozhraní programu jednoduše zvolte některý z dostupných překladů, potvrďte tlačítkem OK a restartujte InfraRecorder. Pokud v nabídce nemůžete najít překlad pro váš jazyk, navštivte domovskou stránku InfraRecorderu a zjistěte, zda je překlad do vašeho jazyka k dispozici.

Rozšíření průzkumníka

Rozšíření průzkumníka (pokud povoleno) přidává dodatečné možnosti do kontextové nabídky průzkumníka:

Přidává možnost přímo vypálit obrazy disků a projekty InfraRecorderu pouhým stisknutím pravého tlačítka myši na daném souboru a zvolením příslušné položky nabídky.

Vzhled rozšíření může být přizpůsoben pomocí následujících voleb:

Zobrazit položky kontextové nabídky jako podnabídku - jednotlivé volby rozšíření nejsou zobrazeny přímo v kontextové nabídce, ale jako podnabídka.

Zobrazit u položek ikony - určuje, zda budou volby čistě textové, nebo u nich budou zobrazeny ikony.

Asociace rozšíření se soubory

Pouhé povolení rozšíření průzkumníka nestačí k tomu, aby se v kontextové nabídce zobrazili příslušné volby, pouze oznámí Průzkumníku Windows, že jsou dané možnosti k dispozici.

Aby Průzkumník Windows možnosti poskytované rozšířením InfraRecorderu použil, musí být rozšíření asociováno s typy souborů, pro které ho chcete použít.

V seznamu jsou již předdefinovány některé typy souborů. Pro aktivaci asociace s daným tipem souborů jednoduše zaškrtněte danou položku seznamu. Své vlastní typy souborů můžete přidat pomocí tlačítka Přidat do seznamu novou příponu souboru: